Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Parâmetro sessão cliente inp - Input Characters

time.png Tempo aproximado para leitura: 00:01:17 min

Ocorrência
Na compilação apresentou a mensagem More than 15000 characters in a single statement--use -inp parm. (135)

Ambiente
Framework - Framework (Linha Datasul) - Sessão Cliente - Versão 12

Causa
No arquivo .pf que o compilador utiliza não tinha o parâmetro -inp parametrizado.

Solução
O parâmetro -inp define o tamanho do buffer de memória utilizado para armazenar cada comando ABL. Para o produto Datasul convencionamos o valor de 32000. Ele é definido no arquivo .pf que a aplicação utiliza.

Em algumas situações na compilação, realizar um teste compilado apenas um programa ou reduzindo a quantidade.

Saiba mais
Informações adicionais referente ao parâmetro inp em:
Framework - Linha Datasul - TEC - Parâmetro sessão cliente inp - Input Characters
ABL program fails to run due low -inp value
More than < value > characters in a single statement--use -inp parm. (135)
Does the r-code of an application need to be recompiled when using the client session startup parameter -inp?

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _