Tempo aproximado para leitura: 00:01:40 min
Ocorrência
No módulo de Prestação de Contas, ao clicar para fazer manutenção de um processo de prestação de contas existente, ocorre a mensagem 8453 - Usuário está fora do período de acesso!
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Prestação de Contas (EEC) - Versão 12
Causa
O erro ocorre pois o usuário que está logado no sistema no momento de Modificar o processo de prestação de contas, é diferente do usuário relacionado ao funcionário desse processo. Nesse cenário o sistema faz algumas validações em relação ao usuário logado e se nenhuma for atendida, a mensagem é apresentada.
Solução
Para solucionar essa ocorrência, faça as seguintes verificações e ajuste conforme necessário para atender o processo da empresa:
-Se o funcionário do usuário logado está relacionado como Responsável de uma Unidade de Aprovação - prgfin/eec/eec018aa.r - que tenha o estabelecimento em branco ou de uma Unidade de Aprovação de seu próprio estabelecimento;
-Ou, se o funcionário do usuário logado está relacionado como Emitente de uma Unidade de Aprovação - prgfin/eec/eec018aa.r - opção Emitentes, que tenha o estabelecimento em branco ou de uma Unidade de Aprovação de seu próprio estabelecimento;
-Ou, se funcionário do usuário logado está relacionado como Responsável Substituto de uma Unidade de Aprovação - prgfin/eec/eec018aa.r - opção Responsável Substituto, que tenha o estabelecimento em branco ou de uma Unidade de Aprovação de seu próprio estabelecimento.
A validade de todos os registros acima citados, precisa estar compreendendo a data do dia em que está sendo feita a tentativa de manutenção do processo para ser considerado.
Tela de exemplo com destaque de cada verificação feita pelo sistema para a mensagem 8453:
0 Comentários