Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - SMT - S-2210 - Erro na validação do campo 'codAgntCausador': Se dtAcid = [2024-01-22] e se tpAcid = [1, 3]

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Ao gerar o XML do evento S-2210, é exibido a seguinte mensagem: Erro na validação do campo 'codAgntCausador': Se dtAcid = [2024-01-22] e se tpAcid = [1, 3], deve ser um código válido e existente na Tabela 14.


Ambiente

TOTVS RH - TOTVS RH (Linha RM) - TOTVS Segurança e Saúde Ocupacional - A partir das versões 12.1.2302.235, 12.1.2306.182, 12.1.2310.116 e superiores.

Causa

Este erro ocorre pois o código gerado na tag 'codAgntCausador' é diferente do que pertence a tabela 14 do eSocial. Segundo regra do Leiaute S-1.3, para este campo quando dtAcid >= [2024-01-22] e se tpAcid = [1, 3], o código deverá estar presente na tabela 14. 

 



Solução

Para correção, basta acessar o cadastro da CAT, e excluir o código do agente causador que foi informado para que possa incluí-lo novamente na visão.
 
image.png
 
Ao ir em incluir um novo, pesquise pelo código do agente causador desejado e edite-o:
 
image.png
 
Assim, será aberta uma nova janela e deverá alterar o 'Tipo de agente' para 'Agente Causador Acidente de Trabalho'.  Dessa forma, no campo 'Cód. eSocial Agente Causador Acidente de Trabalho' serão listados os códigos presentes na Tabela 14 do eSocial.

image.png

Ao selecionar um dos itens da tabela 14 para preenchimento do campo 'Cód. eSocial Agente Causador Acidente de Trabalho', salve as alterações feitas, gere o XML novamente e ao ser gerado poderá realizar o envio do S-2210. 
 

Saiba Mais:

- eSocial - Tabela 14

- RH - RM - SMT - Evento S-2210 - CAT (Comunicação de Acidente de Trabalho)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _