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Ocorrência
Como localizar e retirar o saldo do campo "Qtd. Reserva" (B2_RESERVA) de um produto?
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Todas as versões.
Causa
Quando um produto possui saldo no campo "Qtd. Reserva" (B2_RESERVA), este saldo está reservado ao processo, não sendo possível usar em qualquer movimentação. Muitas vezes é preciso localizar esse saldo para remover a liberação, para usa-lo em outros processos.
No processo de Faturamento, há algumas maneiras de alimentar a "Qtd. Reserva" (B2_RESERVA) de um produto:
- Liberando o produto em um Pedido de Vendas, após liberação de estoque, assim alimentando a tabela de Pedidos Liberados (SC9);
- Realizando inserção de uma reserva na rotina "Controle de Reservas (MATA430)", automaticamente ou manualmente, assim alimentando a tabela de Reservas para Faturamento (SC0);
- Reserva vinculada à um Orçamento, do módulo SIGALOJA, não finalizado, assim alimentando a tabela de "Itens do Orçamento" (SL2).
Observação: Para saber como Localizar/Estornar as reservas das tabelas de Pedidos Liberados (SC9)
e "Reservas para Faturamento" (SC0), consulte o "Saiba mais" no final da documentação.
Solução
Para estorno da "Qtd. Reserva" (B2_RESERVA), é necessário realizar os processos abaixo.
Verificar/Estornar reservas na tabela de "Itens do Orçamento" (SL2):
A reserva que alimenta a "Qtd. Reserva" (B2_RESERVA) está vinculada à um Orçamento não finalizado, o sistema faz a seguinte verificação para manter o saldo reservado:
- Campo "Numero PDV" (L2_PDV) está vazio;
- Campo "Num.Reserva" (L2_RESERVA) está preenchido;
- Campo "Orc.Reserva" (L2_ORCRES) está vazio;
- Campo "Num. Pedido" (L2_PEDRES) está vazio;
- Campo "Status" (L2_VENDIDO) está diferente de "S".
Caso o item do Orçamento esteja com o preenchimento indicado acima, o sistema reserva a quantidade do produto no campo "Qtd. Reserva" (B2_RESERVA).
- A reserva que está vinculada à um orçamento não finalizado, pode ser excluída automaticamente dependendo das configurações do parâmetro "MV_DTLIMIT" e do campo "Dias p/Res." (LJ_DIASRES);
- Também pode ser realizado via rotina "Depuração de Reservas (LOJA540)".
Observação: Dúvidas sobre o processo no módulo SIGALOJA contate o nosso Suporte direcionando à equipe "Protheus Automação Comercial".
Saiba mais:
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