Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Como localizar e estornar o saldo da "Qtd. Reserva" (B2_RESERVA) dos "Itens do Orçamento" (SL2)

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência
Como localizar e retirar o saldo do campo "Qtd. Reserva" (B2_RESERVA) de um produto?

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Todas as versões.

Causa

Quando um produto possui saldo no campo "Qtd. Reserva" (B2_RESERVA), este saldo está reservado ao processo, não sendo possível usar em qualquer movimentação. Muitas vezes é preciso localizar esse saldo para remover a liberação, para usa-lo em outros processos.

 

No processo de Faturamento, há algumas maneiras de alimentar a "Qtd. Reserva" (B2_RESERVA) de um produto:

  1. Liberando o produto em um Pedido de Vendas, após liberação de estoque, assim alimentando a tabela de Pedidos Liberados (SC9);
  2. Realizando inserção de uma reserva na rotina "Controle de Reservas (MATA430)", automaticamente ou manualmente, assim alimentando a tabela de Reservas para Faturamento (SC0);
  3. Reserva vinculada à um Orçamento, do módulo SIGALOJA, não finalizado, assim alimentando a tabela de "Itens do Orçamento" (SL2)

Observação: Para saber como Localizar/Estornar as reservas das tabelas de Pedidos Liberados (SC9)

 e "Reservas para Faturamento" (SC0), consulte o "Saiba mais" no final da documentação.


Solução

Para estorno da "Qtd. Reserva" (B2_RESERVA), é necessário realizar os processos abaixo.

 

Verificar/Estornar reservas na tabela de "Itens do Orçamento" (SL2):

A reserva que alimenta a "Qtd. Reserva" (B2_RESERVA) está vinculada à um Orçamento não finalizado, o sistema faz a seguinte verificação para manter o saldo reservado:

  • Campo "Numero PDV" (L2_PDV) está vazio;
  • Campo "Num.Reserva" (L2_RESERVA) está preenchido;
  • Campo "Orc.Reserva" (L2_ORCRES) está vazio;
  • Campo "Num. Pedido" (L2_PEDRES) está vazio;
  • Campo "Status" (L2_VENDIDO) está diferente de "S".

Caso o item do Orçamento esteja com o preenchimento indicado acima, o sistema reserva a quantidade do produto no campo "Qtd. Reserva" (B2_RESERVA).

  • A reserva que está vinculada à um orçamento não finalizado, pode ser excluída automaticamente dependendo das configurações do parâmetro "MV_DTLIMIT" e do campo "Dias p/Res." (LJ_DIASRES);
  • Também pode ser realizado via rotina "Depuração de Reservas (LOJA540)".

 

Observação: Dúvidas sobre o processo no módulo SIGALOJA contate o nosso Suporte direcionando à equipe "Protheus Automação Comercial".

 

Saiba mais:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _