Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA300 - argument #0 error, expected D->L, function dtos on MA300PROCESS(MATA300.PRX)


time.png Tempo aproximado para leitura: 00:03:12 min

Ocorrência
Ao executar o processamento Refaz Saldos (MATA300) é exibido o error.log: "argument #0 error, expected D->L, function dtos on MA300PROCESS(MATA300.PRX)"

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Este erro ocorre quando a linha do fonte está fazendo validação em parâmetros e comparando com o parâmetro no dicionário de dados do ambiente. Se o tipo do parâmetro esperado no fonte for diferente do tipo que estiver no dicionário de dados, é exibido o error.log em questão.

Solução
Para validar internamente este erro, siga os passos abaixo:
 
1° Passo - validação do tipo dos parâmetros: 
 
Outros 4 parâmetros mais comuns que podem estar com tipagem incorreta a validar no SX6 são: 

MV_D2DTDIG -> Tipo padrão dele é Lógico (L)

MV_A280GRV -> Tipo padrão dele é Lógico (L)

MV_ULMES -> Tipo padrão Data (D)

MV_LOCALIZ -> Tipo padrão Caractere (C)
 
É importante avaliar e eventualmente ajustar caso estejam no ambiente com tipagem diferente do padrão.
 
2° Passo - Estando todos adequados, ou se houve a necessidade de ajustar, desinstale e instale os procedures 14 ao 22. Isso é importante para o Procedure recriar inclusive com as configurações de tipagens dos parâmetros conforme o dicionário de Dados. 
 
3° Passo - Após isso, basta executar o processamento novamente.
 

É esperado que com essas ações, o problema seja resolvido.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Movimentações no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _