Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - TAF - eSocial - Eventos Não Periódicos - S-2200 e S-2205 - Erro de Schema: Elemtent 'nmDep': [facet 'minLength'] The value has a length of '0'; this underruns the allowed minimum length of '2'.

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

Ao tentar transmitir o evento periódico S-2200 (Cadastro Inicial de Vínculo e Admissão) ou o evento S-2205 (Alteração de Dados Cadastrais do Trabalhador) ocorre os erros de Schemas abaixo listados:
Erro de schema: Element
'{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}nmDep': [facet
'minLength'] The value has a length of '0'; this underruns the allowed minimum length of '2'.

Element '{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}nmDep':
[facet 'pattern'] The value '' is not accepted by the pattern '.*[^\s].*'.

Element '{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}dtNascto': ''
is not a valid value of the atomic type
'{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}TS_dtNascto'.

Element '{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}depIRRF':
[facet 'enumeration'] The value '' is not an element of the set {'S', 'N'}.

Element '{http://www.esocial.gov.br/schema/evt/evtAltCadastral/v_S_01_02_00}depSF':
[facet 'enumeration'] The value '' is not an element of the set {'S', 'N'}.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - eSocial - TAF - Todas as versões.

Causa
O erro ocorre devido o acréscimo indevido de uma linha dentro da aba "Dependentes" nos eventos S-2200 ou S-2205.

Solução Paliativa:
1.
Abra o evento S-2200 ou S-2205 para edição, selecionando o botão Alterar:
Automação Fiscal - Não Periódicos - Como acessar a rotina de cadastro do trabalhador. S-2200, S-2300 no TAF



2. Entre na aba Dependestes, e delete a linha criada indevidamente, como no exemplo abaixo:


3. Salve o evento e tente transmitir novamente.

Solução definitiva:

Para corrigir o erro, o ambiente precisa estar atualizado com a última Expedição Contínua do TAF, links para download abaixo:

⚠️ Clientes Segregados, RM, Datasul, Logix, entre outros, apenas aplicar a Expedição Contínua do TAF:

⚠️ Clientes Protheus, além do ambiente TAF, devem se manter atualizados nos demais módulos conforme atualizações encontradas na página Entregas Legais:



Para mais detalhes referente a atualização e como realizá-la, verifique a documentação abaixo:
Automação Fiscal - ATUALIZAÇÃO - Como atualizar o TAF eSocial (Expedição Contínua)?

Saiba Mais
Para saber mais consulte os links abaixo: 
eSocial | Protheus - Entregas Legais
MOS - Manual de Orientação eSocial
Perguntas Frequentes site eSocial

Para conhecimento dos eventos futuros, acessa a nossa página TOTVS Informa selecione em categorias a área e pesquise por "Eventos"

Essa documentação também pode ser acessada 24h por dia e pelo Protheus, através da Carolina: Carolina - Assistente Virtual - Como usar a Carolina pelo ícone no produto Protheus

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _