Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - TOP Error -19 - Invalid parameter type (Erro na chamada de processo)


time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao executar rotinas de processamentos do estoque que utilizam procedures é gerado o erro na chamada de processo "TOP Error -19 - Invalid parameter type", como corrigir? 

 



Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.


Causa
Esse incidente ocorre pois possui algum parametro em sua SX6 que não está com o tipo da variável correto ou o conteúdo, sendo necessário reavaliar se foi feito alguma alteração que impactasse e ajustar para o dicionário correto.

 


Solução

1. Avaliar se não houve nenhuma alteração do tipo da variável dos parametros e conteúdo da sua SX6 relacionado a rotina em questão;

2. Fazer um teste sem as procedures relacionadas ao estoque para que o sistema gere o error.log e informe qual parametro que esteja gerando erro:

Observação: No exemplo acima o erro: "type mismatch on compare on LOCALIZA" se dá por conta do tipo do parâmetro MV_LOCALIZ estar diferente do que se espera. 

Ao gerar o error.log, verifique qual é o parâmetro que está com inconsistência e reavalie. 

3. Avaliar o tipo de compartilhamento do parametro e verificar se está exclusivo ou compartilhado.

Exemplo: Tem 5 filiais no grupo de empresa, e o parametro MV_RASTRO está exclusivo apenas para uma filial, vai gerar o erro acima pois precisa ter esse parametro em todas as filiais. 

4. Caso persista, por gentileza abrir um ticket ao time de Suporte para que possa enviar o error.log sem a procedure instalada gerado para que possamos apontar qual é o parâmetro que está com o tipo incorreto e efetuar o ajuste.

 

Saiba mais:

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Erro na chamada do processo em rotinas de Processamento

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _