Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Mensagem de erro 1461 de incompatibilidade de esquemas com Dataserver SQL Server

time.png Tempo aproximado para leitura: 00:01:44 min

Ocorrência
Na execução da rotina apresenta a mensagem: O detentor do esquema não corresponde ao esquema do banco de dados -- arquivo dbo.tabela campo. Anulando a execução para proteger a integridade do banco de dados e do aplicativo. (1461)

Ambiente
Framework - Framework (Linha Datasul) - SQL Server - Todas as versões

Causa
São várias as causas do erro 1461, conforme listado abaixo:

1. A tabela não existe no banco SQL Server;
2. A tabela existe porém com uma estrutura diferente da prevista;
3. A tabela existe no banco SQL Server e está com a estrutura adequada, porém a sua estrutura prevista, registrada no Schema Holder está desatualizada;

Solução
Seguem as soluções de acordo com as causas listadas, respectivamente:

1. Criar a tabela no banco SQL Server;
2. Ajustar a estrutura da tabela no SQL Server, refletindo o previsto no Schema Holder. Geralmente o erro foi ocasionado devido a falta de importação um script de atualização .sql no SQL Server;
3. Atualizar o Schema Holder para refletir a definição do SQL Server. Geralmente o erro está associado a falta de importação de uma definição de atualização .df no Schema Holder.

Persistindo, abra um ticket enviando o .df do Schema Holder, scripts do banco SQL Server e o Extrato de Versão.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _