Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - Integração - EAI - Erro Modo de compartilhamento

time.pngTempo aproximado para leitura: 00:03:30 min

Ocorrência:
Ao realizar o Diagnóstico de Integrações é apresentado erros dos Adapters:



"Resultado Validação de Adapter Recebimento:
É recomendado a utilização do modo compartilhado por Empresa e Filial, uma vez que este cadastro é global no RM.
Configuração de compartilhamento da tabela inválida, (Exclusivo por Empresa - Compartilhado por Unidade de Negócio - Compartilhado por Filial), o nível de compartilhamento não pode ser diferente entre os níveis que compõem a Filial."


Ambiente:
Cross Segmentos - Backoffice RM - Integração - Todas as versões.


Causa:
Estes erros ocorrem, pois as tabelas no ambiente Protheus não estão compartilhadas conforme o Nível Protheus selecionado.


Solução:

Para solucionar estes erros é preciso validar juntamente com a equipe responsável do Adapter que precisa ser configurado quais as especificações.

Abaixo exemplo de solução:

Veja que deu erro em "Banco, agência e conta" adapter "BANK", no nível Empresa está como "Exclusivo" e o mesmo precisa estar como "Compartilhado".



1. Acesse o sistema Protheus no módulo SIGACFG | Base de Dados | Dicionario | Bases de Dados, print abaixo:


2. Pesquise pela tabela desejada:



3. Acesse o cadastro e edite "1- Compartilhado".


Observação:
Casos que a tabela não deixe editar, pois já estão em uso. Desta forma o sistema Protheus não permite alterar por este caminho.

Detalhes:
Compartilhamento de tabelas bloqueado em tabelas já alimentadas

4. Existe a possibilidade de alterar via Banco no Protheus ( APSDU )

Abrir | Abrir | Drive "Top Connect"


Selecionar a tabela ( SX2 ---- ) que representa seu ambiente Protheus utiliza:


Filtre pelo nome do campo ( X2_CHAVE ) apertando em CTRL + F 


Edite os campos "X2_MODO,X2_MODOUN,X2_MODOEMP" para "C" de Compartilhado


Após veja que o mesmo irá apresentar aviso e não erro


Maiores detalhes:
Detalhes modelos de compartilhamento


Saiba Mais
Cross Segmentos - Backoffice RM - Integração - EAI - Validar comunicação entre RM x Protheus

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _