Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao realizar a conversão EAI 2.0 é apresentado o seguinte erro:
Erro: "Existem transações cadastradas. As novas tabelas do EAI devem estar vazias para a correta execução desse processo!"
Ambiente
Cross Segmentos - Backoffice RM - Integração - Todas as versões.
Causa
Este comportamento ocorre por conta da base já ter sido convertida para EAI 2.0 e retornado para EAI 1.0.
Solução
Para corrigir o erro é preciso limpar as seguintes tabelas via banco de dados:
Segue o select de todas as transações e a ordem que se deve excluir:
1. Tabela em Mensagem Única | Transformações
select * from GEAITRANSACAOVERSAO
2. Tabela em Mensagem Única | Integração | Anexos | Mapeamento de Entidades
select * from GEAITRANSACAO
3. Tabela em Mensagem Única | Integração
select * from GEAITRANSACAOAPP
Observação:
Este procedimento é preciso ser realizado pela TI da empresa responsável pelo banco de dados ou caso seja CLOUD solicitar a equipe para realizar o procedimento.
Importante:
Qualquer alteração via banco é total responsabilidade do cliente.
Saiba Mais
Cross Segmentos - Backoffice RM - Integração - EAI - Como realizar a conversão para EAI 2.0
0 Comentários