Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro de Schema regANS na transmissão do evento S-1210 para o Governo (S-1.2)


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao integrar o evento S-1210 com o governo retorna o Erro de schema: Element '{http://www.esocial.gov.br/schema/evt/evtPgtos/v_S_01_02_00}regANS': [facet 'pattern'] The value 'XXXXX-' is not accepted by the pattern '\d{6}'.


Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - A partir das versões 12.1.23 e Superiores.

Causa 
O erro ocorre quando o número da ANS não consta válido no Registro na Agência Nacional de Saúde - ANS e com 6 dígitos.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse eSocial | Operadora de Saúde | Cadastro Operadoras de Saúde;


2. Identifique a Operadora de Saúde que foi gerada no XML S-1210;

XML S-1210

Operadora de Saúde


3. Verifique se o Registro ANS consta cadastrado corretamente, no exemplo acima, é necessário excluir o item "-" e informar mais um número;


4. Após a correção, regere o XML S-1210.

 

Importante:
Caso o número da ANS conste cadastrado corretamente e mesmo assim o erro persista, será necessário entrar em contato a Agência Nacional de Saúde Suplementar - ANS para conferir se há alguma atualização no Registro ANS, ou entrar em contato com o governo. Abaixo os canais de comunicação:

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _