Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Erro em conexão ODBC/JDBC em Openedge 12

time.png Tempo aproximado para leitura: 00:01:52 min

Ocorrência
Erro em conexão ODBC/JDBC em Openedge 12 com bancos de dados em Red Hat e CentOS.

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - A partir do OpenEdge 12

Causa
É possível reproduzir o erro através de uma conexão via SQLExplorer. Em tela é exibido o erro abaixo:

Error: [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.. (8933)

No log do banco de dados este outro erro:

BROKER 0: (8841) SQL server process terminated.


Solução

Uma das libs utilizadas pelo processo _sqlsrv2 não está instalada no Sistema Operacional. O comando ldd mostra as dependências deste script:

proenv>ldd /usr/dlc/bin/_sqlsrv2
linux-vdso.so.1 (0x00007ffc273ea000)
librt.so.1 => /lib64/librt.so.1 (0x00007f73da419000)
libnsl.so.1 => not found
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f73da1f9000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007f73d9fd0000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f73d9dcc000)
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f73d9a37000)
libm.so.6 => /lib64/libm.so.6 (0x00007f73d96b5000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f73d949d000)
libc.so.6 => /lib64/libc.so.6 (0x00007f73d90db000)
/lib64/ld-linux-x86-64.so.2 (0x00007f73da622000)

A solução é a instalação da libnsl através do comando abaixo:

yum install libnsl

Após a instalação, realize novo teste de conexão via ODBC/JDBC.

Saiba mais
Mais detalhes sobre este erro podem ser obtidas neste artigo da Progress: Errors 8933 and 8841 Trying to Run sqlexp on Centos/Red Hat 8.x

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _