Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - PON - Ao tentar alterar o MV_PONMES, é gerada a mensagem "Não é possível selecionar um período já existente no cadastro de períodos (Tabela SPO). Verifique o período informado"

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
No módulo de Ponto Eletrônico, na Rotina Período de Apontamento, ao tentar alterar o parâmetro MV_PONMES é apresentado a mensagem "Atenção! Existem inconsistências a serem verificadas. Não é possível selecionar um período já existente no cadastro de períodos (Tabela SPO). Verifique o período informado."



Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa 
Esse incidente ocorre, quando informado no MV_PONMES um período que já consta fechado na tabela SPO, e que pode ser consultado na própria rotina de Período de Apontamento, com legenda de cor vermelha.
O incidente também pode ocorrer se o usuário indevidamente criar um período utilizando o botão Incluir, que gera um registro na rotina de Período de Apontamento com a legenda de cor verde.

Solução
Para solucionar essa ocorrência, na Rotina Período de Apontamento, em Atualizações > Cadastro do Ponto > Período de Apontamento, verifique se o período que deseja informar no parâmetro MV_PONMES consta na rotina de Período de Apontamento.

Exemplo abaixo de um período fechado corretamente pelo usuário/sistema, onde a legenda tem cor vermelha. Neste caso, não podemos informar um período no MV_PONMES com datas entre 01.06.2023 e 30.06.2023:



Abaixo, temos um exemplo de registro que foi criado indevidamente pelo usuário utilizando o botão de Incluir, e a legenda tem cor verde. Neste caso, é possível excluir este registro clicando em Outras Ações > Excluir:

 

Importante: Na rotina de Período de Apontamento não deve ser utilizada a opção Incluir, o procedimento correto é que após o Fechamento Mensal, o sistema faça a abertura do Período de Apontamento subsequente alterando automaticamente o conteúdo do parâmetro MV_PONMES e automaticamente subirá o período fechado na tela inicial identificado com a legenda vermelha.

Saiba mais:
Manual do Ponto Eletrônico
Pacote de Expedição Contínua Acumulado de RH
RH - Linha Protheus - PON - Rotina Período de Apontamento - PONA290
RH - Linha Protheus - PON - Após o fechamento mensal, o sistema não alterou o período de apontamento

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _