Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Logix - BI - Corrigindo o erro PKIX path building failed apresentado no log do BI ao tentar realizar o envio de e-mail no Logix BI

time.png Tempo aproximado para leitura: 00:01:40 min

Ocorrência
No log no envio de e-mail no Logix BI apresenta a mensagem PKIX path building failed: unable to find valid certification path to requested target.

Ambiente
Framework - Framework (Linha Logix) – Inteligência empresarial (BI) – A partir da versão 12.01.55

Causa
Falta de certificado a ser importado no servidor do Tomcat onde o Logix BI está instalado.

Solução
Quando executado uma rotina no Logix BI que faz o envio de e-mail e o mesmo não é enviado deve ser verificado no log do BI se o erro abaixo é apresentado:

Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

O erro está relacionado a problemas no certificado no servidor do Tomcat. Desta forma, deverá ser  exportado a chave pública do servidor de e-mail da empresa e em seguida importada no servidor do Tomcat conforme descrito na documentação no Saiba mais em seguida.

Saiba mais
Informações adicionais sobre a mensgem em PKIX path building failed" and "unable to find valid certification path to requested target

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _