Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Tomcat apresenta versão antiga após atualização de versão

time.png Tempo aproximado para leitura: 00:01:42 min

Ocorrência
Após atualização de versão do Tomcat, o serviço apresenta a versão incorreta ou anterior do serviço.

Ambiente
Framework - Framework (Linha Datasul) - Tomcat - Versão 12

Causa
Este cenário ocorre pois durante o processo de atualização, foi feito a cópia do diretório lib completo, com isto levando dados de versão e estrutura antigos do Tomcat, para dentro da nova estrutura.

Solução
Durante a atualização de versão, não devem ser copiados todos os arquivos do diretório lib para a nova instalação, apenas a pasta totvs-lib, caso o ambiente Datasul esteja na versão 2307 ou superior.

Neste caso devem ser mantido o conteúdo original da nova instalação dentro do diretório lib do Tomcat, eliminar o conteúdo das pastas temporárias log, temp e work, e reiniciado o serviço do Tomcat.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _