Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA010 - InterFunctionCall: cannot find function M010GRRSTRUCT in AppMap on VIEWDEF(MATA010.PRX) 06/09/2023 16:09:34 line : 518

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Apresenta o error.log abaixo ao tentar alterar ou copiar um produto na rotina CADASTRO DE PRODUTOS (MATA010). Como ajustar?

 

InterFunctionCall: cannot find function M010GRRSTRUCT in AppMap on VIEWDEF(MATA010.PRX) 06/09/2023 16:09:34 line : 518

[TOTVS build: 7.00.210324P-20230531]
Called from FWLOADVIEW(PROTHEUSFUNCTIONMVC.PRX) 23/05/2023 15:13:33 line : 3838
Called from FWVIEWEXEC:LOADVIEW(FWVIEWEXEC.PRW) 23/05/2023 15:13:33 line : 559
Called from FWVIEWEXEC:OPENVIEW(FWVIEWEXEC.PRW) 23/05/2023 15:13:33 line : 466
Called from FWEXECVIEW(PROTHEUSFUNCTIONMVC.PRX) 23/05/2023 15:13:33 line : 4504
Called from MA010ALTER(MATA010M.PRX) 15/09/2023 14:52:18 line : 847
Called from A010ALTERA(MATA010.PRX) 06/09/2023 16:09:34 line : 1416
Called from FWFORMBROWSE:EXECUTE(FWFORMBROWSE.PRW) 23/05/2023 15:13:33 line : 1147
Called from {|| OSELF:EXECUTE("A010ALTERA", 4, 2,"ALTERAR", 4,"","ALTERAR","", 4) }(FWFORMBROWSE.PRW) 23/05/2023 15:13:33 line : 579
Called from ::MSDIALOG:ACTIVATE
Called from FWMBROWSE:ACTIVATE(FWMBROWSE.PRW) 23/05/2023 15:13:33 line : 700
Called from MATA010M(MATA010M.PRX) 15/09/2023 14:52:18 line : 76
Called from MATA010(MATA010.PRX) 06/09/2023 16:09:34 line : 96
Called from __EXECUTE(APLIB090.PRW) 23/05/2023 15:13:31 line : 721
Called from MDIEXECUTE(APLIB260.PRW) 23/05/2023 15:13:31 line : 924



Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões

Causa

Esse incidente ocorre, devido ausência da Função M010GRRSTRUCT  que consta no fonte MATA010GRR


Solução

Para solucionar essa ocorrência, aplicar o pacote de atualização pontual da rotina abaixo, sugerimos aplicar primeiramente em base de homologação e testar antes de sua base oficial

 

12.1.2210:https://suporte.totvs.com/portal/p/10098/download?e=1120859 ;

 

12.1.2310:https://suporte.totvs.com/portal/p/10098/download?e=1120861 ;

 

12.1.33:https://suporte.totvs.com/portal/p/10098/download?e=1120860 ;

 

Saiba Mais:

Clique aqui e veja mais artigos sobre CADASTROS E CONFIGURAÇÕES GERAIS no Estoque

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _