Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha RM - Fis - REINF - 403 Access is denied

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao gerar os eventos é apresentado no console.log a inconsistência abaixo:
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
<div class="content-container"><fieldset>
<h2>403 - Forbidden: Access is denied.</h2>
<h3>You do not have permission to view this directory or page using the credentials that you supplied.</h3>
</fieldset></div>
</div>
</body>
</html>

Ambiente
Cross Segmento - TOTVS Backoffice (Linha TSS ) - TOTVS Gestão Fiscal - a partir da versão 12.1.33

Causa
A inconsistência indica uma recusa da requisição por parte do destino, e nesse contexto, é o servidor do governo que está recusando o acesso. Essa recusa está diretamente relacionada ao certificado digital utilizado na transmissão do evento.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Na página da Receita perguntas frequentes consta:  Webservice EFD-Reinf no tópico Webservice EFD-Reinf, pergunta: 3.1 - O que fazer quando ocorre o erro "HTTP 403" ao tentar acessar o Webservice da EFD-Reinf?

O erro "403 Forbidden" é um código de erro HTTP retornado pelo servidor web quando o utilizador ou programa tenta obter acesso a um recurso do servidor e este não permite.
Diversos podem ser os motivos que originam este tipo de erro, como por exemplo, acesso utilizando protocolo "http" quando deveria ser "https", cadeia de certificado inválido ou certificado inválido, etc.
A seguir são listadas as causas comuns para este erro:
- Acesso de execução negado.
- Acesso de leitura negado.
- Acesso de escrita negado.
- SSL requerido.
- Endereço de IP errado.
- Certificado do cliente requerido.
- Certificado do cliente revogado.
- Certificado do cliente expirado.
- Cadeia do certificado incorreta
Assim, se ao tentar conectar com o ambiente da EFD-Reinf, foi retornada mensagem de erro 403-Forbidden (Acesso Negado), cuja mensagem em inglês em geral aparece como "403 Forbidden: Access is denied. The request failed with HTTP status 403: Forbidden. The remote server returned an error:(403) Forbidden", sugerimos algumas verificações como as que seguem:
a) Verifique se você está utilizando https://
b) Verifique se seu certificado é válido.
c) Verifique se a cadeia do certificado é válida.
O certificado utilizado, para a transmissão do evento, deverá ter a mesma cadeia de certificado instalada no ambiente de produção restrita do SERPRO. A cadeia utilizada pelo servidor é:
"Autoridade Certificadora Raiz Brasileira v5" (que pode ser encontrada no site http://www.iti.gov.br/repositorio/repositorio-ac-raiz : "Certificado da AC Raiz da ICP-Brasil v5").
Verifique se seu certificado possui a cadeia de certificação abaixo instalada:
- Autoridade Certificadora Raiz Brasileira v5
- Autoridade Certificadora SERPRO v4
- Autoridade Certificadora do SERPRO Final SSL 

2. Realize o checklist no certificado digital importado no RM Gestão Fiscal com base no artigo: Doc. Eletrônicos - Troca de Certificado Digital

3. Verifique a Framework.NET;

4. Verifique há a atualizações importantes pendentes no Windows, caso positivo, realize a atualização;

5. Firewall, antivírus que por algum aplicativo que está bloqueando a conexão;

6.  Após isso, reinicie o serviço do TSS.

Saiba Mais

Para mais informações acesse Eventos Periódicos (Reinf)
Vídeo explicativo

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _