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Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Ao alterar os parametros das perguntas da rotina Acompanha Custo é apresentado o erro de "Internal Server Error", como corrigir?

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - Ao alterar os parametros das perguntas da rotina Acompanha Custo é apresentado o erro de "Internal Server Error", como corrigir?

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Ocorrência

Ao fazer qualquer alteração na pergunta de parametro na rotina Acompanha Custos e salvar é apresentado o erro de "Internal Server Error".


Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.


Causa
Ao fazer uma alteração de perguntas nos parametros da rotina Acompanha Custos e apresentar o erro de "Internal Server Error", é necessário fazer o seguinte procedimento:

1° Habilitar a chave TraceStack em um ambiente exclusivo conforme nossa documentação:

https://tdn.totvs.com/display/tec/TraceStack

 

2° Limpar o console.log.
 
3° Acessar a rotina Acompanha Custos até gerar o erro. 
 
4° Ao gerar o erro em tela validar no console.log e verifique se é apresentado o seguinte erro: 

array out of bounds ( 4 of 3 ) on AC.CONFIG.PROFILE.REPOSITORY.ACPROFREPOSITORY:FIXANDUPDATEPARAMETERSPROPERTY(ACPROFREPOSITORY.TLPP)

Segue imagem de exemplo:


 
Solução
Para correção desse errorlog, precisa validar se possui todos os grupos de perguntas das rotinas Custo Médio e Virada de Saldos na tabela SX1 conforme exemplo abaixo:

Custo Médio/Contabilização offline:

Virada de Saldos:

 

Pois esse erro ocorre quando a base de dados não possui ou consta como deletado algum desses parametros, sendo necessário validar internamente.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - O que é a rotina Acompanha Custos?

Clique aqui e veja mais artigos sobre o Acompanha Custos

 

 

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