Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Mensagem de banco não conectado (1006)

time.png Tempo aproximado para leitura: 03:30:00 min

Ocorrência
Na execução da rotina apresenta a mensagem em tela ou no log de banco não conectado (1006).

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge – Versão 12

Causa
São várias causas, desde o cadastro incorreto no programa BTB962AA - Parametros Foundation, a configuração e compilação do alias.p, entre outros.

Solução
Para a solução da mensagem verifique os passos os seguintes passos:

1.  No cadastro de bancos por empresa no programa BTB962AA NÃO deve ter o banco emsfnd cadastrado, deve ficar somente no arquivo .pf. Se tiver, remova o cadastro;

2. O arquivo .pf da sessão client deverá conectar apenas o banco emsfnd, sendo que os demais bancos serão conectados de acordo com o cadastro no programa BTB962AA;

3. No arquivo .pf do PASOE deve constar todos os bancos, incluindo o emsfnd:

conexao banco pasoe.png

4. O arquivo alias.p do PASOE - Progress Application Server for OpenEdge deve estar no campo Session startup procedure conforme o exemplo da imagem acima. Informar a extensão .p;

5. No diretório onde encontra o arquivo alias.p deve ter o arquivo alias.r compilado. Cada alteração do alias.p é necessário recompilar;

6. Veja se no arquivo de alias.p está o banco que apresenta a mensagem de banco não conectado. O início do arquivo deve conter a linha do exemplo: 

DEFINE INPUT PARAMETER v-parameter AS CHAR NO-UNDO.

CREATE ALIAS emsbas FOR DATABASE emscad NO-ERROR.
CREATE ALIAS emsedi FOR DATABASE emscad NO-ERROR.
CREATE ALIAS emsfin FOR DATABASE emscad NO-ERROR.
.
.

-- no final não há chamada para nenhum programa.

Qualquer alteração na configuração da instância do PASOE é necessário reiniciar.

7. Verificar o cadastro dos bancos por empresa no programa BTB962AA se tem o banco cadastrado, se for unificado, verificar o campo Alias, validar todas as empresas:

BTB.png

8. Configuração o log com o parâmetro DB.Connects do PASOE quando o erro apresenta na tela HTML, se for na tela Progress, incluir no Clientlog para verificar a conexão do banco, se há alguma rotina que está desconectando o banco, simular a rotina em seguida;

9. Diversas situações pode apresentar a mensagem de banco não conectado devido o Propath do Pasoe/Appserver incorreto. Veja o artigo no Saiba mais a Ordem dos diretórios no Propath;

10. Se persistir a mensagem, envie as evidências para acima abrindo um chamado para o Suporte.

Importante
Uma causa comum para este erro em telas html é confundir o local onde o programa de alias é configurado. Conforme orientação no item 4, o local correto é em Session startup procedure e não em Startup procedure parameter. 

Saiba mais
Informações adicionais em:
Framework - Linha Datasul - TEC - Compilar programa de alias
Framework - Linha Datasul - TEC - Conexões de bancos de dados no PASOE para o produto Datasul
Framework - Linha Datasul - TEC - Onde estão localizadas as conexões de banco de dados no ambiente Datasul for THF
Framework - Linha Datasul - TEC - Como ativar o clientlog via arquivo .pf
Framework - Linha Datasul - TEC - Alterar o nível de log do PASOE
Framework - Linha Datasul - TEC - Ordem dos diretórios no Propath

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _