Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - TAF - REINF - Query greater than 32768 bytes. on MPSYSOPENQUERY(MPSYSOPENTABLES.PRW)

 

Produto

TAF - SIGATAF - Release 12.1.33 e superior

 

Causa

 

O problema ocorre devido a falha das nomenclaturas das tabelas do menu, onde o browser faz a contagem de 3 em 3 caracteres, quando o nome está somente como 2 caracteres como B1 e A1, ele se perde não encontrando a tabela, aí entra no loop para encontrar, que acaba criando a query gigante na SX9 causando o error log. 
  

O problema ocorre nos menus que estiverem com o nome da tabela com 2 caracteres e tiver a chamada do extrator fiscal (EXTFISXTAF)

 

Solução 

 

Menu SIGAFIS.XNU

1) Encontrar o arquivo SIGAFIS.XNU
2) Buscar pela rotina FISR017
3) Alterar no item <Tables> que consta a tabela B1, para SB1, ficando da seguinte forma:
<TABLES>SB1</TABLES>.
 

Menu SIGAFIN.XNU

1) Encontrar o arquivo SIGAFIN.XNU
2) Buscar pela rotina FINR960 
3) Alterar no item <Tables> que consta a tabela A1, para SA1, ficando da seguinte forma:
<TABLES>SA1</TABLES>.


Faremos o ajuste no menu do módulo SIGAFIS e a expedição do menu atualizado acontece com a publicação da release 12.1.2310 em Outubro/2023.

Após efetuar o procedimento acima, caso o erro persista, efetue a configuração abaixo no appserver.ini: 

[GENERAL]
MaxQuerySize=65536
 
Abaixo documentação:
 
https://tdn.totvs.com/pages/viewpage.action?pageId=372543595

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _