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Cross Segmentos - Totvs Backoffice Protheus - SIGACOM - Motivo da ocorrência do Help A12020


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Ocorrência
Ao digitar o código do produto no pedido de compras, o sistema gera o help A12020.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGACOM - a partir da 12.1.33

Causa
Para gerar o help A12020, o sistema valida as informações abaixo

Se o campo B1_MONO = S, verifica se o B1_PROC = C7_FORNECE.

Ou seja, quando o campo B1_MONO = S, significa que o fornecimento de um produto será feito por apenas um fornecedor com base na informação do campo Fornecedor Padrão (B1_PROC). O fornecedor responsável por realizar o fornecimento (B1_PROC) deve ser o mesmo fornecedor para o qual o pedido de compras em questão foi emitido, que é armazenado no campo C7_FORNECE.

Solução

Dessa forma, verifique se o fornecedor para o qual está sendo lançado o pedido de compras em questão (C7_FORNECE) é o mesmo que o fornecedor que consta no campo B1_PROC do produto que está sendo digitado.

 

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