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RH - Linha Datasul - Meu RH - Erro ao aprovar, buscar ou enviar o Abono ou Atestado

time.png Tempo aproximado para leitura: 00:03:30 min

Ocorrência
Ao tentar realizar a solicitação, ou a aprovação ou reprovação da solicitação, ou o download ou envio do arquivo de anexo, referente ao abono ou atestado, o Meu RH pode retornar as mensagens:
Erro ao buscar o arquivo de Abono.
Erro ao buscar o arquivo de Atestado.
O arquivo de abono não foi encontrado!
O arquivo de atestado não foi encontrado!
Não foi possível salvar o arquivo da imagem do abono.
Não foi possível salvar o arquivo da imagem do atestado.

Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Meu RH - Versão 12.

Causa
A mensagem é informada caso não seja encontrado o arquivo ou o diretório de catálogo de imagens para onde são enviados os anexos de abono e atestado. Os anexos de abono no Meu RH compartilham o mesmo diretório dos anexos das solicitações de atestado.

Solução
Existem diversas causas raízes para a exibição da mensagem, por isso é necessário verificar:

1. Avaliar se existe catálogo de imagens informado no programa FP0540 - Manutenção Descentralização, pasta Visão Usuário, no campo Catálogo;

2. Verificar se no cadastro do catálogo está informado um diretório válido de rede no programa BTB103AA - Manutenção Catálogo Imagem;

3. Se o ambiente estiver no Sistema Operacional Unix/Linux, o caminho informado deve representar um diretório válido tendo como pontos de atenção o uso correto de caracteres maiúsculos e o uso da barra correta;

4. Garantir que o diretório do catálogo de imagem está informado no propath do PASOE - Appserver;

5. Verifique se o usuário que inicializa o serviço do PASOE - Appserver possui permissão de leitura e escrita para o diretório configurado no catálogo de imagens.
Além disso, de acordo com a documentação oficial da Progress, o tipo de conta que inicializa o serviço do PASOE - Appserver não deve ser do tipo LocalSystemAccount: Appserver e agentes do Webspeed não podem acessar arquivos com uma conta LocalSystem - Em inglês
Se não for possível informar um usuário administrador de rede, será necessário acessar as configurações no Progress Explorer e informar um usuário de rede nas Propriedades do BrokerBrokerOwner information.

6. Avaliar se o arquivo anexado via Meu RH foi depois removido ou renomeado do local.

Se o arquivo não for localizado no diretório de catálogo de imagens de abono ou atestado, será necessário notificar o funcionário sobre o problema e solicitar para que o mesmo faça a exclusão do Atestado ou Abono e realize o relançamento da solicitação.

Saiba Mais
Para mais informações, clique nos links abaixo:
Meu RH - Documento de Referência - Cadastro do catalogo de imagens para atestado medico
Framework - Linha Datasul - TEC - Configurando PROPATH e parâmetros de sessão no PASOE
Framework - Linha Datasul - TEC - Configurando PROPATH e parâmetros de sessão no PASOE através do OpenEdge Explorer
RH - Linha Datasul - Meu RH - Como adicionar diretórios no propath do AppServer

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