Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Mensagem de erro array out of bounds ... on WSPCP:RECEIVEMESSAGE(WSPCP.PRW)

time.png Tempo aproximado para leitura: 00:01:24 min

Ocorrência
Ao integrar um arquivo XML do TOTVS MES com o Sistema, ocorre o error.log array out of bounds ... on WSPCP:RECEIVEMESSAGE(WSPCP.PRW) 

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - Versão 12 

Causa
Esse erro ocorre quando o parâmetro MV_TWSPCP - Definição dos parâmetros utilizados na função ManualJob chamada na função WSPCP. Na seq: nInactive, nMax,nMinFree e nIncr  não possui os quatro valores numéricos que especificam o tempo e números de threads separados por vírgula.

Solução
Preencher no parâmetro MV_TWSPCP os valores pertinentes ao cenário, onde no primeiro valor deve-se informar o tempo de inatividade das threads em segundo, no segundo valor, o número máximo de threads abertas simultaneamente, no terceiro valor o número mínimo de threads livres e no quarto valor o número de threads acrescidas quando a quantidade livre for atingida.

Exemplo
MV_TWSPCP = 20,10,2,3

Saiba mais
No link serviço do MES com diversas conexões simultâneas temos a documentação a respeito desse parâmetro.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _