Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Problemas no login após atualização para release 12.1.2307

time.png Tempo aproximado para leitura: 00:03:09 min

Ocorrência
Após atualização do Datasul for THF para a release 12.1.2307 ocorre erro 500 no log do Tomcat após o  login do produto.

Ambiente
Framework - Framework (Linha Datasul) - Tomcat – Versão 12

Causa
O erro abaixo é exibido no log localhost do Tomcat:

Caused by: java.lang.NoSuchMethodError: 'int org.apache.commons.io.IOUtils.copy(java.io.InputStream, java.io.OutputStream)

Ele ocorre porque o Tomcat está utilizando uma versão incorreta de uma biblioteca.

Solução
O procedimento abaixo deve ser realizado em seu ambiente caso ocorra erro logo após o login no Datasul for THF na release 12.1.2307.
Lembre-se de efetuar um backup do diretório do Tomcat antes de iniciar o procedimento citado.

1. Pare a instância do Tomcat em questão;

2. Edite o arquivo conf/catalina.properties e substitua a linha da propriedade common.loader para o conteúdo abaixo:

common.loader="${catalina.base}/lib","${catalina.base}/lib/*.jar","${catalina.home}/lib","${catalina.home}/lib/*.jar","${catalina.home}/lib/datasul","${catalina.home}/lib/datasul/*.jar","${catalina.base}/lib/datasul","${catalina.base}/lib/datasul/*.jar","${catalina.base}/lib/batik","${catalina.base}/lib/batik/*.jar","${catalina.home}/lib/batik","${catalina.home}/lib/batik/*.jar"

3. Acesse o diretório lib do Tomcat e crie um diretório chamado batik - tomcat/lib/batik;

4. Mova os objetos abaixo do diretório lib/datasul para o diretório lib/batik;

org.apache.batik.bridge-1.6.0.jar
org.apache.batik.css-1.6.0.jar
org.apache.batik.dom-1.6.1.v201505192100.jar
org.apache.batik.dom.svg-1.6.0.jar
org.apache.batik.ext.awt-1.6.0.jar
org.apache.batik.parser-1.6.0.jar
org.apache.batik.pdf-1.6.0.jar
org.apache.batik.svggen-1.6.0.jar
org.apache.batik.transcoder-1.6.0.jar
org.apache.batik.util-1.6.0.jar
org.apache.batik.util.gui-1.6.0.jar
org.apache.batik.xml-1.6.0.jar

5. Elimine os arquivos abaixo do diretório lib/datasul:

org.eclipse.emf.ecore.change-2.11.0.v20160420-0247.jar
org.eclipse.emf.ecore.xmi-2.11.0.v20150512-0501.jar
org.eclipse.emf.ecore.xmi-2.12.0.v20160420-0247.jar
org.eclipse.emf.ecore-2.12.0.v20160420-0247.jar

6. Elimine o conteúdo dos diretórios temporários work, temp e logs;

7. Elimine os diretórios do webapps, mantendo apenas os arquivos .war;

8. Inicie novamente o Tomcat.

Ao final deste procedimento, realize um novo teste de acesso ao produto.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _