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Ocorrência
Ao tentar realizar algum processo no sistema que envolve movimentação de produto, exibe o Help:
AJUDA:FECHTO Não pode ser digitado movimento com data anterior a última data de fechamento (virada de saldos)
Em integração, como por exemplo no PIMS:
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Esse help é exibido pois, realmente, não é permitido realizar movimentações de um produto quando a origem dessa movimentação é anterior á data de fechamento do Estoque. Essa mensagem indica que está tentando movimentar / estornar / modificar registros que já foram "isolados" pelo processo de fechamento do Estoque. Ou seja, tais registros não poderiam, de fato, serem modificados pois já houve fechamento de Estoque do período, e haveria uma quebra de integridade do fechamento.
Solução
1) Verifique a data do último Fechamento do Estoque que foi gravado automaticamente pelo sistema no parâmetro MV_ULMES. Também pode ser conferido pela rotina MATA220 Saldos Iniciais ou pela tabela SB9 - campo B9_DATA.
O registro que está tentando movimentar não pode ser originado de data igual ou anterior à data de fechamento do Estoque, gravado nesse campo/parâmetro, do contrário, irá de fato bloquear.
2) Verifique a data de bloqueio de movimentações no Estoque no parâmetro MV_DBLQMOV.
O registro que está tentando movimentar não pode ser originado de data igual ou anterior à data de bloqueio de movimentos gravada nesse campo/parâmetro, do contrário, irá de fato bloquear.
3) Verifique se o movimento que está tentando processar no sistema é originado de uma data anterior ao fechamento, pois nesse caso, será de fato bloqueado.
São considerados na validação, movimentos originados por qualquer rotina no sistema que gere movimento do produto (independente se a TES está configurada para gerar estoque/financeiro). Exemplo: Documento de Entrada (SF1 e SD1), Documento de Saída (SF2 e SD2), Livros Fiscais (SF3), Ordem de Produção PCP (SH6), Movimentos de Estoque (SD3 e SB9), etc. Verificar os campos de data, exemplo: D3_EMISSAO etc.
4) Se o movimento que está tentando realizar envolve Ordem de Produção PCP, verifique o parâmetro MV_PRODPR0. Se utilizar este parâmetro com conteúdo diferente de 3, o sistema permitirá encerrar a OP quando a data base for anterior à data do fechamento. Essa configuração precisa ser criteriosamente avaliada conforme a regra de negócio da organização. Tratamento implementado através da MATA250 com data igual ou superior a 03/05/2023. Recomendado aplicar Expedição contínua do PCP.
5) Se o movimento que está tentando realizar envolve integração com o sistema PIMS para liberação de Boletim, neste caso, confira se o campo D3_NRBPIMS está devidamente gravado com o número do boletim [Exemplo de condição no ADAPTER via configurador: !Empty(SD3->D3_NRBPIMS) ]
6) Outras possíveis causas / soluções:
- Ambiente desatualizado, ocasionando incompatibilidade entre as validações.
Verifique o comportamento em seu ambiente de teste atualizado com o pacote acumulado - Expedição Contínua dos módulos que utiliza, e demais artefatos do ambiente.
Acumulado SIGAEST | LIB Logo Guará ou Harpia | Appserver Lobo Guará ou Harpia | Smartclient Lobo Guará ou Harpia | DBAccess
- Ambiente sofrendo impacto de customizações (no RPO ou dicionários).
Verifique o comportamento em seu ambiente de teste padrão (RPO e dicionários) seguindo os 3 métodos indicados nesta orientação.
- Validações realizadas por outro sistema, quando o processo envolve integração com o Protheus.
Casos onde o processo é realizado em outro sistema, o qual se integra com o sistema Protheus no Estoque, deve ser avaliada também a regra de negócio deste outro sistema. Quais possíveis configurações e validações podem interferir no comportamento do Estoque Protheus. Uma sugestão para isolar a origem do problema é realizar um teste (em ambiente teste padrão e atualizado) incluindo um movimento diretamente no Protheus (por exemplo, um movimento interno com a data atual) e certificar se realmente aparece o mesmo HELP FECHTO, ou se o problema ocorre somente quando o movimento é originado no outro sistema.
- Inconsistência em registros gravados no banco de dados.
Já foram notados casos onde há inconsistência de dados no banco, não tendo sido ocasionado por processamento padrão do sistema. Nestes casos, não há atendimento de Suporte ao produto, recomenda-se solicitar um DBA para manutenção na base [Exemplo: movimento oriundo de integração com outro sistema, no processamento do Protheus o sistema posiciona em registro em branco na tabela SD3, criado porque o de/para na tabela XXF para o código informado, estava indevidamente deletado na base. Dentre outros exemplos onde há sujeira na base de dados]. Sujeiras no banco de dados comprometem o correto processamento do sistema.
Observações complementares:
- O sistema permite incluir NF de Entrada digitando uma data de emissão (D1_EMISSAO e D1_DTDIGIT) anterior à data do parâmetro MV_ULMES porém, impede a inclusão de NF com a data base do sistema anterior à data do parâmetro MV_ULMES. Este é um comportamento conceitual, O procedimento esta correto. O sistema bloqueia inclusão de NF com a data base do sistema retroativa a data do parametro MV_ULMES.
- Caso já tenha realizado todas as validações aqui indicadas, e não identifique a origem do problema, contate o Suporte Técnico mencionando as validações já realizadas conforme esta documentação, e solicite nossa Consultoria do Suporte para investigação em seu ambiente. Teremos prazer em atendê-lo!
Saiba Mais:
SIGAFAT - Exclusão Documento de Saída apresentado: HELP FECHTO
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