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Cross Segmentos - Backoffice RM - Integração - TAS - Cabeçalho totvsapiservices-api-key não encontrado

time.pngTempo aproximado para leitura: 00:02:30 min

Ocorrência

Ao tentar utilizar um serviço do TAS, é apresentado a seguinte mensagem de erro:

"Ocorreu um problema na execução do serviço
Não foi possível obter as informações.

Code: totvsapiservices.usage-tracker.no-token (400)
Message: Cabeçalho totvsapiservices-api-key não encontrado
DetailedMessage: "


Ambiente
Cross Segmentos - Backoffice RM - Integração - Todas as versões.


Causa
Este erro ocorre devido à chave token necessária para utilização de alguns serviços do TAS, não ter sido corretamente configurada nos parâmetros globais da integração do Totvs Api Services (TAS).


Solução
Para corrigir o erro é necessário configurar a chave token adquirida no TOTVS Store, para correta utilização dos serviços do TAS que exigem esta chave, para ser realizada a requisição.

Acesse os Parâmetros Globais > Integração TOTVS API Services e insira sua chave token adquirida:



Chave de autenticação(Token): Informe a chave gerada, conforme a documentação "Sobre o Totvs API Services" se for utilizar os serviços não listados no Consumo ilimitado.


Saiba mais:

Com relação à configuração do TAS, segue abaixo nossa documentação:

Cross Segmentos - Backoffice RM - Integração - TAS - Como configurar o TAS - TOTVS API Service

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