Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Falha ao obter conexão com o Appserver

time.png Tempo aproximado para leitura: 00:03:10 min

Ocorrência
No log do Tomcat apresenta a mensagem Falha ao obter conexão com o Appserver.

Ambiente
Framework - Framework (Linha Datasul) - Appserver – Versão 12

Causa
Diversas causas como a configuração da conexão incorreta, serviço do Appserver/PASOE parado, número de agentes insuficiente, programa não localizado no propath do Appserver/PASOE.

Solução
Para verificar a conexão verifique os itens a seguir:

1 - Para que o acesso ao produto funcione corretamente, deverá ser apontada na configuração do Tomcat a localização do Appserver Progress, o qual fará a comunicação entre a interface HTML e os bancos de dados. Acesse o diretório onde encontra-se instalado o Tomcat, verifique o arquivo conf\context.xml na tag Context e veja qual é o Appserver/PASOE que o produto utiliza, exemplo:

<Environment name="totvs.appserver" type="java.lang.String" value="AppServer://JV-CAT-TST01:5162/Datasul_12_1_24_NF"/>

Verifique se as informações estão corretas, como IP/Host, porta do nameserver e o nome do Appserver ou instância do PASOE. Se o arquivo for alterado é necessário reiniciar o serviço do Appserver.

2 - No servidor de Aplicação Appserver ou instância do PASOE, veja se o serviço está ativo;

3 - Também verifique se apresenta a mensagem não existem sessões Agentes disponíveis. Neste caso, revise se o Appserver ou a instância do PASOE configurado possui o número adequado de sessões configuradas para que o produto possa realizar as requisições corretamente:

4 - Verifique no log do Appserver ou da instância do PASOE se apresenta mensagem de programa não encontrado, validar o propath do serviço se está correto conforme o artigo no Saiba mais.

Saiba mais
Informações sobre configuração do Appserver Progress no Tomcat em Framework - Linha Datasul - TEC - Configuração do Appserver Progress no Tomcat
Configuração do PASOE no produto Datasul for THF em Framework - Linha Datasul - TEC - Como configurar o PASOE no produto Datasul for THF
Agentes do AppServer Progress em Framework - Linha Datasul - TEC - Agentes do AppServer Progress ocupados
Conferência e ajuste do Propath em Framework - Linha Datasul - TEC - Ordem dos diretórios no Propath
Configurando PROPATH do PASOE Framework - Linha Datasul - TEC - Configurando PROPATH e parâmetros de sessão no PASOE
Log do PASOE Framework - Linha Datasul - TEC - Alterar o nível de log do PASOE
Log do Appserver Progress Framework - Linha Datasul - TEC - Alterar nível do arquivo de log no Appserver Progress
Informações sobre URL de conexão do Pasoe em Framework - Linha Datasul - TEC - Localizando a URL de acesso a uma instância do Pasoe

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _