Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Backoffice RM - BI - Erro em relatórios Delphi "Operação com ponteiro inválida"

Cross Segmentos - Backoffice RM - BI - Erro em relatórios Delphi "Operação com ponteiro inválida"


time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar gerar relatórios Delphi, na visão.Net ou Delphi é apresentada a mensagem de erro operação com ponteiro inválida.

mceclip1.pngmceclip0.png


Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - Todas as versões


Causa
Esse incidente ocorre, pois quando existe uma falha de comunicação do sistema operacional com o driver de impressora padrão, ou seja, caso possua alguma falha, ausência de privilégios ou desatualização do driver é apresentado o erro, está é uma das primeiras verificações realizadas pelo Gerador Dephi.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1 - Acesse Painel de Controle > Hardware e Sons > Dispositivos e Impressoras;

2 - Adicione uma impressora local genérica, defina a mesma como padrão e tente gerar novamente;


mceclip3.png

3 - Verifique se o driver da impressoras virtuais utilizadas estão atualizados.

4 - Realize a limpeza do Spooler de Impressão

5 - Reinstale o host utilizando a opção de Local Sytem.



Importante

 Em caso de ambiente N camadas, é necessário verificar os servidores de JOB e APP.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _