Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - MEU RH - Chave duplicada tabelas RH3, RH4 e ou ACB após reiniciar o license server

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Chave duplicada tabelas RH3, RH4 e ou ACB após reiniciar o license server

Ambiente
TOTVS RH (Linha Protheus) - MEU RH - Todas as versões

Causa
A numeração das tabelas em License Server é armazenada em memória, enquanto o License Server está ativo. 

Quando o serviço do License Server é parado, é criado um arquivo chamado LSNumber.val na pasta do Application Server. Neste arquivo são gravadas as últimas sequências das chaves em uso no License, das tabelas que possuem numeração automática. 

Quando o License é reiniciado, esses dados são lidos desse arquivo e carregados em memória novamente, para dar continuidade na sequência da numeração automática.

Caso o License Server seja parado de forma inesperada, como uma queda de energia ou fechamento inadequado, o arquivo não é gerado, e não há reinicialização do License, as informações da última numeração são lidas diretamente das tabelas no banco e carregadas em memória.

Solução
1. Para que não ocorra a  perda do controle de numerações, deve ser configurado a tag SpecialKey no appserver.ini e apontando para os respectivos ambientes, pois as sequencias do License são obtidas por meio da tag, junto ao ID da Tabela.

Para saber mais como realizar essa configuração acesse:
Numeração sequencial via License Server

Após verificar no console do rest ou do dbaccess em qual tabela esta ocorrendo a chave duplicada. depois deve ser realizado o ajuste do controle de numeração pelo Configurador(SIGACFG) através da rotina APCFG110.

Obs: Quando o erro apontar nas tabelas RH3 ou RH4 o processo de alteração abaixo deve ser feito SEMPRE na tabela RH3, Nunca na RH4. Quando ocorrer o erro na tabela ACB o processo deve ser feito na tabela ACB.

Próximos números:


Números gravados no banco:


Para saber mais como realizar esse ajuste acesse:
Ajuste de Numeração automática

IMPORTANTE: Caso entenda que o comportamento do MEU RH deva ser diferente sugerimos que realize a solicitação de uma melhoria através da Central Colaborativa TOTVS.

É possível acompanhar as funcionalidades já disponíveis e o planejamento do que está por vir através do ROADMAP MEU RH - PROTHEUS.

Para saber como criar uma sugestão de melhoria clique AQUI, e para cadastrar uma nova sugestãoAQUI.

Saiba Mais:
CLIQUE AQUI para acessar mais artigos e FAQs sobre o MEU RH
CLIQUE AQUI para acessar a documentação de referências sobre o MEU RH

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _