Tempo aproximado para leitura: 00:03:00 min
Ocorrência
Chave duplicada tabelas RH3, RH4 e ou ACB após reiniciar o license server
Ambiente
TOTVS RH (Linha Protheus) - MEU RH - Todas as versões
Causa
A numeração das tabelas em License Server é armazenada em memória, enquanto o License Server está ativo.
Quando o serviço do License Server é parado, é criado um arquivo chamado LSNumber.val na pasta do Application Server. Neste arquivo são gravadas as últimas sequências das chaves em uso no License, das tabelas que possuem numeração automática.
Quando o License é reiniciado, esses dados são lidos desse arquivo e carregados em memória novamente, para dar continuidade na sequência da numeração automática.
Caso o License Server seja parado de forma inesperada, como uma queda de energia ou fechamento inadequado, o arquivo não é gerado, e não há reinicialização do License, as informações da última numeração são lidas diretamente das tabelas no banco e carregadas em memória.
Solução
1. Para que não ocorra a perda do controle de numerações, deve ser configurado a tag SpecialKey no appserver.ini e apontando para os respectivos ambientes, pois as sequencias do License são obtidas por meio da tag, junto ao ID da Tabela.
Para saber mais como realizar essa configuração acesse:
Numeração sequencial via License Server
Após verificar no console do rest ou do dbaccess em qual tabela esta ocorrendo a chave duplicada. depois deve ser realizado o ajuste do controle de numeração pelo Configurador(SIGACFG) através da rotina APCFG110.
Obs: Quando o erro apontar nas tabelas RH3 ou RH4 o processo de alteração abaixo deve ser feito SEMPRE na tabela RH3, Nunca na RH4. Quando ocorrer o erro na tabela ACB o processo deve ser feito na tabela ACB.
Próximos números:
Números gravados no banco:
Para saber mais como realizar esse ajuste acesse:
Ajuste de Numeração automática
IMPORTANTE: Caso entenda que o comportamento do MEU RH deva ser diferente sugerimos que realize a solicitação de uma melhoria através da Central Colaborativa TOTVS.
É possível acompanhar as funcionalidades já disponíveis e o planejamento do que está por vir através do ROADMAP MEU RH - PROTHEUS.
Para saber como criar uma sugestão de melhoria clique AQUI, e para cadastrar uma nova sugestão, AQUI.
Saiba Mais:
CLIQUE AQUI para acessar mais artigos e FAQs sobre o MEU RH
CLIQUE AQUI para acessar a documentação de referências sobre o MEU RH
0 Comentários