Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Errolog contendo a mensagem Os tipos de dados image e image são incompatíveis no operador equal to ao atualizar a demanda ou em inglês The data types image and image are incompatible in the equal to operator

time.png Tempo aproximado para leitura: 00:03:30 min

Ocorrência
Ao atualizar as demandas através do PCPA136 - Demandas do MRP ocorre a mensagem Os tipos de dados image e image são incompatíveis no operador equal to ou a mensagem em inglês The data types image and image are incompatible in the equal to operator

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - Versão 12

Causa
Essa mensagem ocorre quando os campos memo das tabelas relacionadas na expressão SQL - Standard Query Language possuem tipos diferentes no banco de dados

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Observe a expressão SQL listada logo abaixo da mensagem;
2. Nesta expressão SQL, verifique quais são as tabelas que possuem campos _MOPC - Memo listados;
3. Faça um backup dessas tabelas;
4. Delete do banco de dados;
5. No dbaccess.ini inclua a chave MemoAsBlob=1;
6. Reinicie o dbaccess e o appserver;
6. Acesse as rotinas que criam essas tabelas para que as tabelas sejam recriadas;
7. Restaure o backup.

Exemplo:
Considerando a mensagem de erro:
: Error : 402 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Os tipos de dados image e image são incompatíveis no operador equal to.
( From tMSSQLConnection::GetQueryFile )
Thread ID [10516] User [newbridge] IO [651] Tables [29] MaxTables [30] Comment [PCPA136 - TCPIP - ThreadID(16648)] SP [ ] Traced [No] SQLReplay [No] InTran [Yes] DBEnv [MSSQL/DADOSP12] DBThread [(SPID 61,63)] Started [10/05/2021 21:28:30] IP [10.1.2.62:1413] IDLE [ ] InTransact [1 s.] Memory [0] Running [ROP_QUERY for 0 s.] RCV [25381] SND [25097] TCBuild [20200606-20201012] TCVersion [20.1.1.0] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
SELECT TMP.RECPRV RECPREVISAO, SVR.R_E_C_N_O_ RECDEMANDA FROM SVR010 SVR, dbo.##TMPSC00_61 TMP, SC4010 SC4 WHERE SVR.VR_FILIAL = '01' AND SVR.VR_CODIGO = 'TST202105 ' AND SVR.VR_TIPO = '2' AND SVR.VR_REGORI = TMP.RECPRV AND SVR.D_E_L_E_T_ = ' ' AND SC4.R_E_C_N_O_ = SVR.VR_REGORI AND EXISTS( SELECT 1 FROM SC6010 SC6, SF4010 SF4 WHERE SC6.C6_FILIAL = '01' AND SC6.C6_PRODUTO = SC4.C4_PRODUTO AND (SC6.C6_BLQ = ' ' OR SC6.C6_BLQ = 'N ') AND SC6.C6_QTDENT < SC6.C6_QTDVEN AND SC6.D_E_L_E_T_ = ' ' AND SF4.F4_FILIAL = '01' AND SF4.F4_CODIGO = SC6.C6_TES AND SF4.F4_ESTOQUE = 'S' AND SF4.D_E_L_E_T_ = ' ' AND ((SC6.C6_MOPC IS NULL AND SC4.C4_MOPC IS NULL) OR (SC6.C6_OPC = SC4.C4_OPC) OR (SC6.C6_MOPC = SC4.C4_MOPC) ) AND SC6.C6_OP <> '02' AND SC6.C6_ENTREG >= SC4.C4_DATA AND YEAR( CAST(SC4.C4_DATA AS DATE)) = YEAR( CAST(SC6.C6_ENTREG AS DATE)) AND MONTH(CAST(SC4.C4_DATA AS DATE)) = MONTH(CAST(SC6.C6_ENTREG AS DATE)) AND ((DAY(CAST(SC4.C4_DATA AS DATE)) BETWEEN 1 AND 15 AND DAY(CAST(SC6.C6_ENTREG AS DATE)) BETWEEN 1 AND 15) OR (DAY(CAST(SC4.C4_DATA AS DATE)) BETWEEN 16 AND 31 AND DAY(CAST(SC6.C6_ENTREG AS DATE)) BETWEEN 16 AND 31)) ) ORDER BY SVR.VR_FILIAL, SVR.VR_CODIGO, SVR.VR_DATA, SVR.VR_PROD on PRCQTDPREV(PCPA136IMP.PRW) 08/04/2021 23:03:32 line : 1600

Observe que as os campos _MOPC relacionados são C6_MOPC - Memo e C4_MOPC - Memo. Neste caso, execute os passos abaixo:

1. Faça um backup das tabelas SC6 - Pedido de Venda e SC4 - Previsão de Venda;
2. Delete do banco de dados essas duas tabelas;
3. No Dbaccess inclua a chave MemoAsBlob=1;
4. Reinicie o dbaccess e o appserver;
5. Acesse as rotinas MATA410 - Pedido de Venda e MATA700 -  Previsão de Vendas para que as tabelas sejam recriadas;
6. Restaure o backup.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _