Ocorrência
Após a implementação da API Carol, ao tentar informar o CPF ou CGC está gerando a mensagem:
Help Regnois - Problema: Não existe registro relacionado a chave informada no alias CC3, ordenação 1.
Causa
Além da mensagem de Regnois, dentro do processo poderão ser gerados outras duas mensagens:
Erro de preenchimento do cnae do cliente:
Atenção:
O problema ocorre devido a validação do campo A1_CNAE para o tratamento de integração com a API Carol.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Sigafat - a partir da release 12.1.27.
Solução
Para solucionar:
1- Aplique o pacote de expedição contínua no módulo que já contém a correção em questão, via Vs-code, para a release em vigência:
12.1.33: https://suporte.totvs.com/portal/p/10098/download?e=1039091
1-a Para as releases expiradas seguem os pacotes disponíveis:
12.1.17:https://r.totvs.io/p/1021956 (garantia estendida);
12.1.23:https://r.totvs.io/p/1021957 ;
12.1.25:https://r.totvs.io/p/1021958 ;
12.1.27:https://suporte.totvs.com/portal/p/10098/download?e=954520;
2-Valide se a validação do A1_CNAE está igual a A30VldCnae() . Caso não esteja, aplique o dicionário diferencial de Faturamento que se encontra no pacote de expedição contínua: SIGAFAT
E execute o upddistr para os ajustes de dicionário.
Observação: Para aplicação de pacote e atualização de dicionários, requer que o analista tenha pelos conhecimentos de estrutura Protheus.
2 Comentários