Tempo aproximado para leitura: 00:01:20 min
Ocorrência
Qual cadastro deverá ser realizado para corrigir o erro de Região não cadastrada?
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) – Contas a Receber (ACR) – Versão 12
Causa
O erro ocorre devido não existir a região informada no cadastro de Representante - CD0708 e cadastro de Pessoa Jurídica - prgint/utb/utb006aa.r ou Pessoa Física - prgint/utb/utb030aa.r.
Solução
No cadastro de programa Manutenção de Representantes do Produto Datasul - CD0708, a informação de região é um item obrigatório para o cadastramento do representante.

Neste caso, sempre que um representante for cadastrado no Financeiro o campo condado no cadastro da Pessoa Jurídica - prgint/utb/utb006aa.r ou Pessoa Física - prgint/utb/utb030aa.r do representante deverá ser preenchido com a informação equivalente a uma região previamente cadastrada no programa Manutenção Gerais Distribuição Região - CD0707.

Importante
No caso de integrar cadastros de Clientes e Fornecedores pelo Financeiro, o Sistema também avalia a informação de microrregião do programa Cadastros Gerais Microrregião - CD0306, mas não é uma informação obrigatória no cadastro de Manutenção Cliente - CD0704 e Manutenção Fornecedor - CD0401. Logo não se faz necessário informar no campo Condado o código de uma Microrregião válida.
No caso de uma pessoa ser Cliente, Fornecedor e Representante temos uma situação diferente, pois o Condado será obrigatório para atender a situação de obrigatoriedade da região do representante, será necessário que exista também uma Microrregião com o mesmo código para que o cadastro fique correto.
0 Comentários