Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Mensagem Could not be completely deleted. The presence of the remaining files may cause problems

time.png Tempo aproximado para leitura: 00:01:31 min

Ocorrência
Após a atualização do produto Datasul, apresenta erro no login.  No arquivo de log do Tomcat tem a seguinte mensagem: java.io.IOException: [E:\totvs\datasul\dts-12\srvAplicacaoTomcat\instance-8080\apache-tomcat-9.0.31\webapps\totvs-menu] could not be completely deleted. The presence of the remaining files may cause problems


Ambiente
Framework - Framework (Linha Datasul) - Tomcat - Versão 12

Causa
A mensagem é apresentada devido a uma tentativa de publicação dos arquivos .war, porém o Tomcat não está conseguindo eliminar todos os arquivos dos diretórios que já estão publicados. O Console de Atualização não faz nada mais do que baixar os arquivos .war no diretório. Depois disso, o Tomcat inicia, identifica que os diretórios estão em versão diferente dos .war e os republica. Pode ser também um problema de permissão nos diretórios ou do usuário.

Solução
Para solucionar a mensagem execute o seguinte procedimento:

1. Parar o serviço do Tomcat
2. Fazer um backup do diretório webapps
3. Eliminar todos os diretórios que existem dentro do diretório webapps, mantendo apenas os arquivos .war
4. Iniciar o Tomcat e realizar novo teste.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _