Ocorrência
O campo vendedor não é apresentado na posição do cliente após a atualização.


Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - a partir da release 12.1.17.
Causa
O campo vendedor deixou de ser exibido na alteração do finc010 de 22.12.2020, a equipe de desenvolvimento de produto do Financeiro, efetuou uma limpeza no fonte com retirada de funções não compiladas, onde estavam relacionadas a função ACAR590, módulo do Protheus Educacional , que não esta compilado no RPO, devido a descontinuidade de uso do módulo em questão, retirando todos os trechos que faziam menção a ele através do parâmetro MV_ACATIVO.
If ! lSigaGE
@ 023,206 SAY STR0057 SIZE 035,07 OF oDlg PIXEL //"Vendedor"
@ 030,206 MSGET SA1->A1_VEND SIZE 053,09 WHEN .F. OF oDlg PIXEL
EndIf
Todavia, o campo Vendedor é de uso comum em outros módulos que se integram com a rotina de Posição de Clientes (Finc010), desta forma, a informação passou a reintegrar a rotina a partir de 09.03.2021, sendo necessária a aplicação do expedição contínua do módulo Financeiro no ambiente para reaver a chamada deste campo na consulta posição de clientes.
Solução
Para que o campo Vendedor apareça normalmente na Consulta Posição de Clientes, siga os seguintes passos:
1-Baixe o pacote de Expedição contínua do Financeiro, conforme a sua release:
- https://suporte.totvs.com/portal/p/10098/download#detail/954746 12.1.27
- https://suporte.totvs.com/portal/p/10098/download#detail/817562 12.1.25
2-Via VS-Code, aplique a atualização em seu ambiente de homologação para validar e posteriormente no ambiente de produção.
3- Reinicie o Smartclient e abra a consulta Posição de Clientes, para validar a inclusão do campo Vendedor na consulta.

0 Comentários