Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - INF - Totvs Atualiza - Erro ORA-00942: a tabela ou view não existe


Ocorrência
Ocorreu um erro ao iniciar a aplicação.
Contato o administrador ORA-00942: a tabela ou view não existe.

err.PNG

Ambiente
Retail Manager System, V12R23, V12R27, V12R31.

Causa
Devido a falta de algumas tabela, ocorre esse erro ao abrir o 'Atualiza'.

Solução

Passo 1:

Abra o PL/SQL com usuário que tenha permissões para criação de tabelas.
Passo 2:

Rode o script abaixo:

-- Create table
create table GE_ATUALIZACAO
(
seqatualizacao NUMBER not null,
sistema VARCHAR2(30) not null,
pacote VARCHAR2(100) not null,
status VARCHAR2(1) default 'S' not null,
usuultatualizacao VARCHAR2(30),
dtaultatualizacao DATE,
versaopacote VARCHAR2(100) default 'ND' not null
);

-- Create table
create table GE_ATUALIZACAOLOG
(
seqatualizacaolog NUMBER not null,
seqatualizacao NUMBER,
dtahoraexec DATE not null,
arquivopdc VARCHAR2(100) not null,
nrolinha NUMBER not null,
indicecomando NUMBER not null,
falha VARCHAR2(4000) not null,
cmdsql VARCHAR2(4000) not null
);

create table GE_ATUALIZACAO_JOBS
(
nome_instancia VARCHAR2(100),
valor VARCHAR2(10)
);

create table GE_ATUAUDITORIADDL
(
dtahorevento DATE,
username VARCHAR2(30),
ipclient VARCHAR2(256),
osuser VARCHAR2(60),
terminal VARCHAR2(60),
modulo VARCHAR2(60),
tipoevento VARCHAR2(30),
tipoobjeto VARCHAR2(18),
ownerobjeto VARCHAR2(30),
nomeobjeto VARCHAR2(128),
cmdsql CLOB
);

create table GE_AUDITORIADDL
(
dtahorevento DATE,
username VARCHAR2(30),
ipclient VARCHAR2(256),
osuser VARCHAR2(60),
terminal VARCHAR2(60),
modulo VARCHAR2(60),
tipoevento VARCHAR2(30),
tipoobjeto VARCHAR2(18),
ownerobjeto VARCHAR2(30),
nomeobjeto VARCHAR2(128),
cmdsql CLOB
);

create sequence s_ge_atualizacao;
create sequence s_ge_atualizacaolog;

create table MAX_PARAMETRO
(
parametro VARCHAR2(30) not null,
grupo VARCHAR2(30) not null,
nroempresa NUMBER(3) not null,
valor VARCHAR2(250),
tipodado VARCHAR2(1) not null,
comentario VARCHAR2(252),
indreplicacao VARCHAR2(1),
indgeroureplicacao VARCHAR2(1),
dtahoralteracao DATE,
usualteracao VARCHAR2(12),
versao NUMBER
);

 

Passo 3:

Após criação das tabelas realizadas , abra novamente o 'Atualiza'.

 

OBS: Executar como Administrador o 'Atualiza'

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _