Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - Doc. Eletrônicos - NFSE - variable does not exist C5_ENDPRES on PRESTACAO(NFSEXMLENV.PRW) DD/MM/AAAA HH:MM:SS line : 2141

Ocorrência
Ao realizar a transmissão de um RPS ocorre o error.log: "variable does not exist C5_ENDPRES on PRESTACAO(NFSEXMLENV.PRW) DD/MM/AAAA HH:MM:SS line : 2141"

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Todas as versões

Causa
Esse error.log é causado quando está sendo utilizado a configuração MP - NFSE - Dados da Prestacao: Endereço, Número, Complemento, Bairro, CEP e PAIS, porém com o parâmetro MV_ENDPRES configurado incorretamente, geralmente sem a separação de cada campo por aspas simples ( ' ).

Solução
Para correção, a estrutura do parâmetro deverá ser a seguinte abaixo, separado por aspas simples:

{'C5_ENDPRES','C5_NUMPRES','C5_COMPPRE','C5_BAIPRES','C5_CEPPRES','C5_PAIS'}

Feito isso, é de extrema importância reiniciar o Protheus para surgir efeito nas alterações.

Obs.: Vale lembrar que o nome dos campos poderá variar de acordo com o que foi criado e configurado através da documentação citada acima, porém a estrutura do parâmetro deverá ser padrão.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _