Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - INF - Totvs Atualiza - Erro ORA-01722 INVALID NUMBER

Ocorrência
Ao abrir o atualiza aparece mensagem de erro abaixo:

Ocorreu um erro ao iniciar a aplicação. Contate o administrador!
ORA-01722 INVALID NUMBER


Ambiente
Retail Manager System, V12R27, V12R31.

Causa
Algum dado na tabela AA1verob está errado em versões, somente são aceitos dados numéricos. 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Passo 1:

Necessário  abrir o PL/SQL  e utilizar o select abaixo:

SELECT upper(TRIM(Pc_Rms_Amb_Banco.f_Nome_Objetos(a.Ver_Nome))) Ver_Nome, a.Ver_Versao, a.Ver_Data FROM Aa1verob a


Passo 2:

Verificar na consulta as informações de acordo com exemplo abaixo:

dados.PNG

Visto que em versão está V5.681.01 e são aceito somente números se faz necessário UPDATE  

Passo 3;

SELECT upper(TRIM(Pc_Rms_Amb_Banco.f_Nome_Objetos(a.Ver_Nome))) Ver_Nome, a.Ver_Versao, a.Ver_Data FROM Aa1verob a for update

Click no campo com a informação errada e realize alteração.

Utilizando a referência acima deve ser alterado DE: V5.681.01 PARA: 5.681.01 retirando o 'V' ou qualquer outro caractere que não seja números.

 

Passo 4: 

Após update dar comite, e abrir novamente o atualiza.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _