Ocorrência
Ao realizar operações diversas no TOTVS Gestão Financeira como Acordos, inclusão de Boletos, Baixas ou Cancelamentos de Baixa, a operação não é concluída e a mensagem abaixo é apresentada:
"Não é possível gerar Nosso Número pelo Id. do Lançamento".
Ambiente
RM - TOTVS Gestão Financeira - Todas as versões
Causa
Normalmente esta mensagem é exibida quando no Convênio associado ao(s) lançamento(s), não existe uma definição para a forma de geração de Nosso Número. Como os dados do Nosso Número do boleto são validados nas operações que mencionamos acima, a mensagem é exibida já que o sistema não consegue calcular o novo Nosso Número.
Solução
O primeiro passo para contarmos esta situação é realizar a seguinte validação:
- Edite o(s) lançamento(s) envolvido(s) na operação, vá na aba Valores e verifique se o campo Convênio está preenchido e em caso positivo, anote o código;
- Acesse então o menu Movimentações Bancárias;
- Clique em Convênio;
- Localize e edite o Convênio informado no(s) lançamento(s);
- Acesse a aba Dados Adicionais;
- Verifique o preenchimento atual da opção Nosso Número - Tipo Nosso Número;
Se esta opção estiver sem preenchimento, a mensagem realmente será exibida. Neste caso, é preciso definir uma das opções disponíveis, salvar a alteração e realizar novamente a operação.
Observações
Uma outra possibilidade para esta mensagem ser exibida é a do Convênio associado aos registros envolvidos estarem com informações indevidas ou inconsistentes no banco de dados. Neste caso, se a opção da imagem acima estiver correta, um procedimento válido seria regravar o Convênio nos Lançamentos Financeiros envolvidos.
Saiba mais
Para saber mais sobre Boletos, acesse nosso TDN, clicando aqui. Caso deseja obter mais detalhes sobre a inclusão de Convênio, acesse o documento específico. Para isso, clique aqui.
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