Ocorrência
Ao parametrizar uma nova coligada, observa-se a necessidade de adequação da máscara do Cliente/Fornecedor. Contudo, ao informar a nova máscara na etapa Cliente/Fornecedor do parametrizador e tentar salvar a modificação, o sistema retorna a mensagem abaixo e não efetiva a alteração:
"A máscara definida para o cli/for não pode ser alterada, pois já existem clientes e/ou fornecedores utilizando a atual definição".
Ambiente
Cross Segmentos - Backoffice Linha RM - TOTVS Gestão Financeira - Todas as versões
Causa
Esta mensagem pode ocorrer caso exista algum cadastro de Cliente/Fornecedor na coligada em questão. Neste caso o sistema realmente não permite a alteração da máscara, já que ela foi utilizada nos cadastros já gravados.
Caso não exista nenhum Cli/For cadastrado na coligada ainda, o motivo da mensagem normalmente é a permissão de clientes/fornecedores globais, que já possuem uma máscara definida.
Solução
Para solucionar este incidente, siga os passos descritos abaixo:
- Acesse o menu Ambiente;
- Clique em Parâmetros;
- Escolha a opção TOTVS Gestão Financeira;
- Clique em Avançar;
- Clique no processo 02.01 - Contas a Pagar;
- Depois em 02.01.01 - Manutenção de Lançamentos;
- Clique em Avançar;
- Navegue até a etapa Cliente/Fornecedor;
- Neste local, desabilite a opção "Permite Globais";
- Salve esta modificação nos parâmetros;
- Efetue um Logout/Login;
- Retorne a mesma etapa do parametrizador e verifique se a alteração da máscara será permitida e gravada corretamente na coligada.
Saiba mais
Para obter mais informações a respeito do cadastro de Cliente/Fornecedor, acesse nosso TDN específico, clicando aqui.
0 Comentários