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Cross Segmentos - Backoffice Linha RM - FIN - "A máscara definida para o cli/for não pode ser alterada, pois já existem clientes e/ou fornecedores utilizando a atual definição".

Ocorrência
Ao parametrizar uma nova coligada, observa-se a necessidade de adequação da máscara do Cliente/Fornecedor. Contudo, ao informar a nova máscara na etapa Cliente/Fornecedor do parametrizador e tentar salvar a modificação, o sistema retorna a mensagem abaixo e não efetiva a alteração:

 

"A máscara definida para o cli/for não pode ser alterada, pois já existem clientes e/ou fornecedores utilizando a atual definição".

 

mceclip0.png

Ambiente
Cross Segmentos - Backoffice Linha RM - TOTVS Gestão Financeira - Todas as versões

Causa
Esta mensagem pode ocorrer caso exista algum cadastro de Cliente/Fornecedor na coligada em questão. Neste caso o sistema realmente não permite a alteração da máscara, já que ela foi utilizada nos cadastros já gravados.

Caso não exista nenhum Cli/For cadastrado na coligada ainda, o motivo da mensagem normalmente é a permissão de clientes/fornecedores globais, que já possuem uma máscara definida.

Solução
Para solucionar este incidente, siga os passos descritos abaixo:

  1. Acesse o menu Ambiente;
  2. Clique em Parâmetros;
  3. Escolha a opção TOTVS Gestão Financeira;
  4. Clique em Avançar;
  5. Clique no processo 02.01 - Contas a Pagar;
  6. Depois em 02.01.01 - Manutenção de Lançamentos;
  7. Clique em Avançar;
  8. Navegue até a etapa Cliente/Fornecedor;
  9. Neste local, desabilite a opção "Permite Globais";

    PermiteGlobais.png

  10. Salve esta modificação nos parâmetros;
  11. Efetue um Logout/Login;
  12. Retorne a mesma etapa do parametrizador e verifique se a alteração da máscara será permitida e gravada corretamente na coligada. 

 

Saiba mais
Para obter mais informações a respeito do cadastro de Cliente/Fornecedor, acesse nosso TDN específico, clicando aqui.

 

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