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Ocorrência
Ao alterar o pedido de compra no SUP1582/SUP22001 – Manutenção de Pedidos de Compra apresenta a mensagem: Pedido de consignação não é de remessa. Não permite Modificação.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Compras - Versão 12
Causa
O Sistema gera essa mensagem em duas ocasiões:
1 - Quando no SUP7170 - Parâmetros Consignação o parâmetro Ordem/Pedido remessa manual está como S - Sim, valida se o grupo ou o tipo de despesa da ordem são os mesmos informados nos campos Grupo despesa faturamento ou Tipo despesa faturamento do SUP7160, caso um deles sejam iguais, gera a mensagem.
Neste caso se na ordem for informado um grupo ou tipo de despesa diferente daquele informado nos parâmetros será possível realizar a alteração.
2 - Quando o parâmetro Ordem/Pedido remessa manual no SUP7170 está como V - Somente complemento valor, e o tipo ou grupo de despesa da ordem forem diferentes dos informados nos parâmetros do SUP7170, campos Grupo despesa remessa ou Tipo despesa remessa e a ordem não for de valor, ou seja, houver uma quantidade informada na ordem, gera a mensagem.
Para este caso se a ordem for de valor e o grupo ou tipo de despesa for igual ao informado no parâmetro será possível realizar a alteração.
Solução
Quando o pedido/ordem é de consignação o Sistema não irá permitir a alteração pois há tabelas do módulo do Faturamento envolvidas, assim o procedimento é cancelar e fazer um novo pedido e ordem.
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