FAQs - Suporte técnico

Cross Segmentos - Linha Datasul - NFE - Falha de schema na Tag TCnpj

time.png Tempo aproximado para leitura: 00:00:55 min

Ocorrência
Ao enviar a nota fiscal para a SEFAZ - Secretaria da Fazenda ocorre a falha de schema http://www.portalfiscal.inf.br/nfe:CNPJ' element is invalid - The value '' is invalid according to its datatype 'http://www.portalfiscal.inf.br/nfe:TCnpj' - The Pattern constraint failed.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFE) - Todas as versões

Causa
O erro ocorre quando a nota está sendo enviada para um cliente nacional mas o endereço está como estrangeiro, ou seja, a UF - Unidade Federativa está como EX. Se no programa CD0704 - Manutenção de Clientes o campo Natureza, da pasta Fiscal, está definido como Pessoa Física, Pessoa Jurídica e Trading o cliente é considerado nacional e gera no arquivo XML a Tag <CNPJ> no bloco <dest>. O endereço precisa ser nacional para que não ocorra o erro. Apenas para a natureza Estrangeiro é que o endereço pode ser cadastrado como sendo do exterior, porque neste caso gera a Tag <idEstrangeiro> no XML.

Solução
Verifique como está definido o campo Natureza no programa CD0704. Se for Pessoa Física, Pessoa Jurídica e Trading o endereço informado na pasta Endereço deve ser nacional.

01.jpg

2.jpg

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _