Tempo aproximado para leitura: 00:03:45 min
Ocorrência
Após a migração para o Datasul for THF apresenta a mensagem Conexão com o Datasul Interactive recusada.
Ambiente
Framework - Framework (Linha Datasul) - Tomcat - Versão 12
Causa
Parametrização incompleta do ambiente ou bloqueio de porta.
Solução
Listamos um checklist para a validação do ambiente que possa estar bloqueando a abertura do DI:
1 - É necessário a instalação do TOTVSLauncherDI para o ambiente Datasul for THF. O instalador está disponível no diretório de instalação do TOMCAT, abaixo de webapps\totvs-menu\install. Mais informações no artigo no Saiba mais.
2 - Edite o arquivo ..\ERP\scripts-8X80\datasul-progress.ini e configure a variável promsgs, como no exemplo:
PROMSGS=c:\dlc117\promsgs
Mais informações no artigo no Saiba mais.
3 - Verifique se a porta configurada para o DI está disponível no Sistema operacional do servidor TOMCAT. Valide também se há bloqueio pelo firewall ou em uso por outro aplicativo. Se necessário, altere para outra porta livre em Ferramentas > Propriedades do Sistema > Parâmetros gerais
Podem ocorrer problemas no DI quando essa porta está bloqueada ou em uso. A comunicação entre o HTML e DI ocorre por este endereço de IP e a Porta.
4 - Reinicie o serviço do Tomcat, especialmente quando são realizados ajustes no ambiente.
5 - Teste se o programa fwk/utils/diProgress.r em Configurações, Propriedades do Sistema. Propriedades Atalhos de Execução, está acessível no produto. Execute os 3 comados abaixo, de forma distinta, no prompt, exemplo:
C:\dlc117\bin\prowin32.exe -pf C:/totvs/datasul/dts/ERP/scripts-8080/datasul.pf
C:\dlc117\bin\prowin32.exe -ininame C:/totvs/datasul/dts/ERP/scripts-8080/datasul-progress.ini
C:\dlc117\bin\prowin32.exe -p fwk/utils/diProgress.r
O terceiro comando apresentará erro de passagem de parâmetros, mas o objetivo é apenas testar se ele está acessível.
6 - Faça uma pesquisa pelo programa men\men906za.wrx no Propath do ambiente e renomeie ou elimine todos os arquivos encontrados. Recomendamos fazer backup do arquivo antes da exclusão.
7 - Verifique se há permissão no diretório raiz do Sistema. Se não houver, forneça as permissões e realize novo teste de abertura do DI.
8 - Avaliar o cadastro de Appservers por empresa no programa BTB962aa - Parâmetros Foundation se em outras empresas está apontando para o Appserver do ambiente correto. Conferir todas as empresas. A informação fica gravado na tabela fnd_empres do banco emsfnd. Se precisar alterar, no menu superior tem o botão Modificar A.
Se a mensagem Conexão com o Datasul Interactive recusada! ocorre de forma intermitente no produto ou com alguns usuários, solicitamos que seja aberto um ticket para o Suporte de Datasul Framework.
Saiba mais
Artigos complementares para auxiliar na solução:
Item 1: Framework - Linha Datasul - TEC - Datasul Interactive não foi iniciado
Item 2: Framework - Linha Datasul - TEC - msgOpen unable to open message file PROMSGS
Glossário
DI - Datasul Interactive
THF - TOTVS HMTL Framework
HTML - HyperText Markup Language
IP - Internet Protocol
0 Comentários