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Cross Segmento - TOTVS Backoffice (Linha Protheus) - FINA460 - Help FIN460AGRV

Ocorrência
Ao efetuar uma Liquidação a Receber (FINA460) apresenta uma mensagem Help FIN460AGRV
teste_1.png

Ambiente
Microsiga Protheus – Financeiro – A partir da versão 12.1.17

Causa 
Ocorre quando já possui um título em sua base com as mesmas informações que está para gerar. 


Solução
A mensagem apresentada não caracteriza um erro do sistema, mas sim uma validação da rotina ao identificar que já existe um título na base com a mesma combinação de informações do registro que está sendo gerado.

Nas versões mais recentes, a rotina também passou a validar corretamente os campos configurados como obrigatórios, comportamento que anteriormente não ocorria em determinadas operações.

Os campos Prefixo, Número, Parcela e Tipo de Título compõem a chave primária da tabela SE1, portanto não é permitido existir mais de um título com a mesma combinação dessas informações.

Dessa forma, orientamos:

  • Validar as informações apresentadas no help da mensagem;
  • Conferir se já existe registro na tabela SE1 com os mesmos dados;
  • Caso necessário, realizar o preenchimento correto da pergunta disponível no parâmetro F12 antes da execução da rotina.
    teste_2.png

Em alguns casos, após a apresentação da mensagem inicial, pode ocorrer a exibição do seguinte help:

“AJUDA:OBRIGAT - Um ou mais campos obrigatórios não foram preenchidos. xxxxxxxxxxxxxx -> xxxxxxxxxxxxx Histórico”

O exemplo apresentado na ocorrência indica que o campo Histórico está configurado como obrigatório na tabela SE1. Com isso, ao realizar a liquidação pela rotina FINA460, o sistema exige o preenchimento desse campo para permitir a geração do novo registro.

Para que o processo seja concluído corretamente, será necessário:

  • Ajustar a configuração do campo para que ele deixe de ser obrigatório; ou

Implementar tratamento/customização ou até mesmo gatilho que realize o preenchimento do campo obrigatório durante a execução da rotina FINA460.


Importante

O campo Histórico foi utilizado apenas como exemplo. O sistema poderá apresentar a mesma ocorrência para quaisquer outros campos configurados como obrigatórios.

 

 

 

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