Ocorrência
Ao acessar à rotina MATA010 - Cadastro de Produtos e fazer alguma alteração, é apresentado o HELP REGBLOQ, indicando que Cliente ou Fornecedor está bloqueado na SA1/SA2.
Ambiente
Microsiga Protheus - Estoque - A partir da versão 12.1.17
Causa
Este erro ocorre quando o Produto possui registro no campo Forn. Padrão (B1_PROC) e este está bloqueado/inativado no seu cadastro, seja Cadastro de Fornecedores (SA2) - MATA020 ou Cadastro de Clientes - MATA030 (SA1)

Solução
Para resolver este produto, temos 2 alternativas:
1° - Desvincular o Fornecedor/Cliente do Cadastro do Produto, apagando o que estiver preenchido no campo Forn. Padrão (B1_PROC);
2° - Identificar o Fornecedor/Cliente que está vinculado ao produto e, na rotina MATA020 (Fornecedores) ou MATA030 (Clientes) para reativá-lo.
Caso seja Cliente
Acessar à rotina MATA020, localizar o cliente e alterar o campo Status (A1_MSBLOQ) para 2 - Ativo, conforme imagem abaixo:

Caso seja Fornecedor
Acessar à rotina MATA030, localizar o fornecedor e alterar o campo Bloqueado? (A2_MSBLOQ) = Nao, conforme imagem abaixo:

Após seguir a alternativa 1 ou 2 descritas no artigo, será possível fazer a alteração cadastral do produto normalmente.
Saiba mais:
MP - SIGAEST - MATA010 - HELP: UM.Industria (Unidade de Medida do WMS)
Clique aqui e veja mais artigos sobre Cadastros e Configurações Gerais no Estoque
0 Comentários