Ocorrência
Na rotina Venda Assistida/Venda Direta (LOJA701), os campos Nome Vend. e Nome Cliente não estão aparecendo no filtro de Pesquisa por Coluna, conforme abaixo:

Ambiente
Microsiga Protheus – SIGALOJA – A partir da versão 12
Causa
Pesquisa com campo virtual desabilitada.
Solução
Ao utilizar um campo virtual com um Posicione para ter seu conteúdo preenchido, o browse permite habilitar esse campo para ser utilizado na pesquisa do browse através da opção de pesquisa padrão, além de preencher seu conteúdo normalmente de acordo com as informações enviadas.
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse a Configuração da Tabela clicando no ícone da engrenagem no canto superior direito da tela (conforme exemplo abaixo).

2. Em Configuração da tabela, clique em Pesquisa e filtros;
3. Habilite a opção: Habilita pesquisa com campo virtual (conforme exemplo abaixo);

4. Salve as alterações e verifique que os campos serão exibidos no filtro de Pesquisa por Coluna conforme exemplo abaixo:

Saiba Mais
Para mais informações, acesse a documentação: https://tdn.totvs.com/display/public/PROT/Posicione+com+Campo+Virtual
0 Comentários