Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - HELP MA280FLOCK em Rotinas de Processamentos


Ocorrência
Ao executar rotinas como: Refaz Saldos (MATA300), Refaz Acumulados (MATA215), Recálculo do Custo Médio (MATA330), Fechamento de Estoque (MATA280) gera-se o HELP MA280FLOCK.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

Causa
Este help é causado quando a rotina tenta travar uma tabela específica (que é mostrada no HELP) para que ela seja utilizada no processamento porém possui uma outra conexão utilizando a tabela, não permitindo assim prosseguir o processamento


Solução
Para este problema temos soluções a depender da rotina.

 

Para rotinas Recálculo do Custo Médio (MATA330) e Refaz Saldos (MATA300)

Para estas rotinas, pode-se adotar a alternativa de desabilitar o parâmetro MV_CUSTEXC, que permite ou não utilizar estas rotinas em modo exclusivo.

 

Para demais rotinas de processamento

Outras rotinas de processamento são executadas apenas de forma exclusiva, conforme exemplo abaixo da rotina Refaz Acumulados:

mceclip0.png

 

Para estes casos, a solução é identificar envolvem os seguintes passos:

1° - Checar se há algum JOB habilitado;

2° - Checar se existe alguma conexão presa à alguma rotina ou tabela que o processamento faz checagem;

3° - Checar qual usuário poderia estar acessando à rotina/tabela;

4° - Reiniciar os serviços do Protheus e tentar executar novamente.

 

Saiba mais:

Clique aqui e veja mais artigos sobre Processamentos no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _