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RMS - INF - Objeto inválido PC_PEDIDO_ORDP

Ocorrência

Após aplicação de SP, o erro ocorre com esse objeto inválido PC_PEDIDO_ORDP.

Ambiente
Retail Manager System - V12R23, V12R27 E V12R31.

Causa
o cliente possui um script da tabela AA1CMPCP aplicado em sua base diferente da tabela de mesmo nome que temos na release.

Solução

No caso, o ideal seria dropar e recriar esta tabela utilizando o script correto, presente no pacote da release, script:

 

-- Create table
create table AA1CMPCP
(
CP_PRODUTO NUMBER(7),
CP_LOJA NUMBER(7),
CP_PEDIDO NUMBER(7),
CP_QTDE NUMBER(13,3)
)
tablespace &&TS_RMS_D
pctfree 10
initrans 1
maxtrans 255
storage
(
initial 16K
minextents 1
maxextents unlimited
);

-- Create/Recreate indexes
create unique index IA1CMPCP1 on AA1CMPCP (CP_PRODUTO,CP_LOJA,CP_PEDIDO)
tablespace &&TS_RMS_I
pctfree 10
initrans 2
maxtrans 255
storage
(
initial 16K
minextents 1
maxextents unlimited
);

alter table AA1CMPCP
add constraint PK_AA1CMPCP primary key
(CP_PRODUTO,CP_LOJA,CP_PEDIDO) using index
tablespace &&TS_RMS_I;

COMMENT ON COLUMN AA1CMPCP.CP_PRODUTO IS 'PRODUTO COMPONENTE';
COMMENT ON COLUMN AA1CMPCP.CP_LOJA IS 'FILIAL';
COMMENT ON COLUMN AA1CMPCP.CP_QTDE IS 'QUANTIDADE SUGERIDA';
COMMENT ON COLUMN AA1CMPCP.CP_PEDIDO IS 'PEDIDO VENDAS';

 

Atenção antes de realizar o processo realizar 'BACKUP'.

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