FAQs - Suporte técnico

MP - FAT - O código sequencial do cadastro de cliente Vtex não segue o Padrão do Protheus.  Como validar os campos A1_COD e A1_LOJA na integração.



Ocorrência

O código sequencial do cadastro de cliente Vtex não segue o Padrão do Protheus.  Como validar os campos A1_COD e A1_LOJA na integração.

Ambiente

Protheus  – Faturamento – A partir da versão P12

Causa

Quando o Vtex integra com o Protheus  o campos A1_COD assume a numeração dos 8 primeiros dígitos  da chave única do Vtex, exemplo: 
Chave única do Vtex: InternalId":"b7ab9d5n-ce24-43a2-8a5f-419f61ad1a38",

CustomerVendorId":"b7ab9d5n-ce24-43a2-8a5f-419f61ad1a38"

O sistema grava no  Protheus  A1_COD : b7ab9d5n 


Solução

Esta é uma tratativa padrão da integração, então mesmo que utilize  GetSxeNum ou numeração por CNPJ no código do cliente (A1_COD) no Protheus, o sistema permanece gravando os 8 primeiros dígitos da chave única  do Vtex. 

Para tratar este caso tem a possibilidade de utilizar os Pontos de entrada:

MTI030NOM: https://tdn.totvs.com/pages/releaseview.action?pageId=181144392

MT030EAI: https://tdn.totvs.com/display/public/PROT/TTNAQ4_COM_DT_Ponto_de_Entrada_MT030EAI

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _