FAQs - Suporte técnico

Cross Segmentos - Backoffice RM - BI - O operador Equal não é permitido no RM Reports

time.png Tempo aproximado para leitura: 00:01:40 min


Ocorrência
No RM Reports, após converter um relatório Delphi, é apresentada a mensagem erro ao executar relatório, o operador Equal não é permitido.

                                       mceclip1.png

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - Todas as versões

Causa
Esse incidente ocorre devido ao formato inválido definido no componente Expressão utilizado na estrutura do relatório. Este componente é configurado de forma diferente nos relatórios Delphi, e após a conversão dos relatórios, em alguns casos é preciso ajustá-los. 

Nos relatórios em Delphi, utilizamos o componente Espelho para repetir uma informação já no Reports é preciso inserir uma Expressão quando desejamos esse comportamento. A expressão por sua vez, terá que ser configurada, isto é, informando se o dado gerado pela expressão é Geral, data e etc., e efetuar a ligação com o campo a ser repetido.

 

Exemplo de uma expressão em um formato incorreto no RM Reports, após a conversão do Relatório:

                               mceclip2.png

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Localize o componente na estrutura do relatório;
  2. Clique em editar o componente;
                                    mceclip3.png
  3. Identifique a informação que deve ser retornada no componente e altere para o formato esperado;

                                 mceclip0.png

Saiba mais
Acesse nosso artigo para mais informações sobre RM - BI - Cálculos matemáticos em expressões do RMREPORTS

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _