Ocorrência
No módulo Faturamento, ao tentar realizar o faturamento do produto de um determinado Pedido através da tela PEDFM003, é apresentada a mensagem: Quantidade do produto da transação maior que disponível!
Ambiente
TOTVS Varejo - TOTVS Moda - Faturamento.
Causa
A mensagem é apresentada, porque o produto que está tentando faturar, possui o estoque, porém elas está sendo consumidas nas outras transações que se encontra em andamento.
Outro motivo da mensagem, ela pode ser apresentada também quando o produto não possui quantidade em estoque.
Neste caso, será necessário realizar uma verificação se o produto possui quantidade em outras transações em andamento e verificar se o produto possui estoque.
Solução
Para solucionar essa ocorrência, realize as seguintes verificações:
1. Acesse o componente PRDFL017 - Consulta Kardex por Produto, através do campo Procurar... na Lupa e tecle Tab ou Enter;
2. No campo Empresa, informe a empresa desejada;
3. No campo Saldo, selecione o tipo de saldo para consulta;
4. No campo Data, informe o período da data;
5. No campo Produto, informe o código do produto apresentada na mensagem;
6. Tecle F4 ou clique na Lupa para consultar;
7. Após as informações da consulta listadas, caso o produto possui saldo em estoque, anote o saldo atual; 
8. Em seguida, saia do componente PRDFL017 e acesse o componente TRAFL037 - Consulta Movimento de Produto para Transação;
9. No campo Empresa, informe a empresa desejada;
10. No campo Data, informe um período de data do início do ano até a data atual;
11. No campo Situação, selecione a opção Em andamento;
12. No campo Tipo operação, selecione a opção Saída;
13. No campo Produto, informe o código do Produto apresentada na mensagem;
14. Tecle F4 ou clique na Lupa para consultar;
15. Caso seja apresentada transações em andamento para este produto, realize a conta:
Saldo atual - quantidade total do produto apresentado na tela TRAFL037 = quantidade disponível.
Exemplo: 6 - 4 = 2 unidades disponível.
Importante:
Na tela TRAFL037, ao consultar o produto em andamento na transação, e não apresentar nenhuma transação em andamento do ano atual, realize a consulta com o período de data do ano anterior.
Outro ponto importante, é sempre validar qual é a operação está sendo utilizada no Pedido e consultar o saldo do produto com o Tipo de Saldo que está cadastrado na operação.
0 Comentários